Author Topic: Using V25 on MAC is very slow  (Read 930 times)

nunya

  • Community Member
  • Posts: 10
  • Hero Points: 0
Re: Using V25 on MAC is very slow
« Reply #15 on: January 12, 2021, 08:37:49 pm »
> fast scrolling option?

Yes, on and off. It's on by default. Off was slower.

Dennis

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 3245
  • Hero Points: 461
Re: Using V25 on MAC is very slow
« Reply #16 on: January 13, 2021, 03:26:59 pm »
OK, let's try this.

1) Open <slickedit>/macros/ada.e in your editor
2) Go to line 1.
3) Use a stopwatch app on your phone or a physical stopwatch to time this
4) Hold down the cursor-down key until you hit the bottom of the file.
5) Let me know how many seconds that takes.

Now close the editor and from a Terminal, open a new instance with a default configuration:
Code: [Select]
    open -a SlickEditPro2020 --args -sc /tmp/defcon1
Then repeat the steps above again.  Just to see if there is any difference.

Also, are any of your source files on a remote file system?

Also, do you have the mini-map feature enabled?  I noticed that you had the "Delayed Minimap Update for Faster Scrolling" disabled in your configuration.

Finally, how may source files do you typically have open in the editor at once?  Do you mainly see delays when editing files with very long lines?

Do you have SoftWrap enabled?
« Last Edit: January 13, 2021, 03:31:07 pm by Dennis »

rajkej

  • Senior Community Member
  • Posts: 308
  • Hero Points: 13
Re: Using V25 on MAC is very slow
« Reply #17 on: January 13, 2021, 04:03:26 pm »
Just to give you data points from another user:

1) SE 25.0.1, my config, hold down cursor down key, ada.e, 181 seconds (~10 lines/second)
2) Textedit, hold down cursor down key, ada.e, 186 seconds

When I use the mouse scroll wheel or page down in SE, I can get through the file (ada.e) very quickly. Page down is ~4 seconds, mouse scroll wheel takes me ~10 seconds.

My keyboard repeat in system preferences, keyboard, is set at the max slider location minus one tick. My delay until repeat is on the 'short' setting. I'm running catalina 10.15.7.

So then I did a key repeat test by making a new file in SE and holding down the 'a' key.

3) SE 25.0.1, my config, hold down 'a' key. 98 chars in ~10 seconds, still ~10 key repeat/second.

Then I changed my keyboard repeat to the max slider location, the delay between is still set to 'short'

4) SE 25.0.1, my config, hold down cursor down key, ada.e, 60 seconds, ~30 key repeat/second.

And to be complete, I did the open with new config you mentioned. This is with the keyboard repeat to the max slider location and delay set to short just like test 4.

5) SE 25.0.1, clean config, hold down cursor down key, ada.e, 60 seconds.

HTH

Clark

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 5771
  • Hero Points: 460
Re: Using V25 on MAC is very slow
« Reply #18 on: January 13, 2021, 04:08:30 pm »
> fast scrolling option?

Yes, on and off. It's on by default. Off was slower.

It does seem like something odd is going on with the settings you are using. I haven't quite figured it out. If you turn off the minimap, that seems to improve things. Using the minimap with a default config does not have any scrolling performance problems.

Clark

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 5771
  • Hero Points: 460
Re: Using V25 on MAC is very slow
« Reply #19 on: January 13, 2021, 04:26:43 pm »
If I removed the following settings from your "user.cfg.xml", then I get good performance

<minimap_delayed_updating v="0"/>
<mac_use_scroll_performance_hack v="0"/>

I would have thought you would only need to remove the first setting but the second setting must be removed as well.

The first setting is accessible from the context menu of the minimap "Delayed Minimap Updating for Faster Scrolling". You have turned this off. You definitely want this turned on.

The second setting is here: Tools>Options>Appearance>Advanced>macOS faster editor scrolling.  You have this turned off. Turn this back on.

nunya

  • Community Member
  • Posts: 10
  • Hero Points: 0
Re: Using V25 on MAC is very slow
« Reply #20 on: January 13, 2021, 07:02:12 pm »
1) Open <slickedit>/macros/ada.e in your editor
2) Go to line 1.
3) Use a stopwatch app on your phone or a physical stopwatch to time this
4) Hold down the cursor-down key until you hit the bottom of the file.
5) Let me know how many seconds that takes.

Now close the editor and from a Terminal, open a new instance with a default configuration:
Code: [Select]
    open -a SlickEditPro2020 --args -sc /tmp/defcon1
Then repeat the steps above again.  Just to see if there is any difference.

Thanks Denis. This is very helpful.

Code: [Select]
SlickEdit with my config and a workspace open - 136s
SlickEdit with my config and a workspace closed - 133s
SlickEdit with default config - 64s
TextEdit - 60s
Visual Studio Code - 60s

Also, are any of your source files on a remote file system?

No.

Also, do you have the mini-map feature enabled?  I noticed that you had the "Delayed Minimap Update for Faster Scrolling" disabled in your configuration.

Yes it is enabled. I will look for it and turn it on. I haven't touched that, so whatever has been imported over the years. Just to be clear.

Just to be clear, scrolling is just one of the issues. I have a ton of problems trying to edit code.

I've been using SlickEdit for ~30 years. I started with the command line version (it would be great if that was still around too). The Visual SlickEdit, I believe I've updated from version to version over that time frame. I can't be entirely sure what I did as I changed jobs. There may have been some clean restarts over time, but I just can't recall.

Finally, how may source files do you typically have open in the editor at once?  Do you mainly see delays when editing files with very long lines?

It is hard to say exactly. I have anywhere from 10-50 or more. In this particular case, I'm making a small change and only have about 10 files open.

I do notice there are performance issues when I open a Xcode project vs a just using a directory, as well. But, one step at a time. The main issues are navigation and code editing.

Do you have SoftWrap enabled?

No. I did not turn that on. Where is this setting and how to turn it off, if on?

If I removed the following settings from your "user.cfg.xml", then I get good performance

<minimap_delayed_updating v="0"/>
<mac_use_scroll_performance_hack v="0"/>

Thanks, that helps a lot. The last one was on already. I must've posted the file while doing experiments with Dennis. I did not realize I turned off the minimap optimization. I haven't timed it, but it seems much more responsive already.

I'll give it a go with code modifications and see if those problems persist as well.

Side question. I'd like to purge a lot of my config, what's the best way to set certain things back to default? As mentioned, I import my config over years and I really don't recall what most things are configured as. The most important to me are the colors, and the whitespace management (different projects have different requirements, don't ask...).

Clark

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 5771
  • Hero Points: 460
Re: Using V25 on MAC is very slow
« Reply #21 on: January 13, 2021, 07:25:04 pm »
To fix your scrolling performance problem do the following:

if I remove the following settings from your "user.cfg.xml", then I get good performance

<minimap_delayed_updating v="0"/>
<mac_use_scroll_performance_hack v="0"/>

I would have thought you would only need to remove the first setting but the second setting must be removed as well.

The first setting is accessible from the context menu of the minimap "Delayed Minimap Updating for Faster Scrolling". You have turned this off. You definitely want this turned on.

The second setting is here: Tools>Options>Appearance>Advanced>macOS faster editor scrolling.  You have this turned off. Turn this back on.

nunya

  • Community Member
  • Posts: 10
  • Hero Points: 0
Re: Using V25 on MAC is very slow
« Reply #22 on: January 13, 2021, 07:27:27 pm »
To fix your scrolling performance problem do the following:

Thanks Clark, already called you out in my prior response. :) Yes, that helps that. Now I just need to see if it affects my code editing problem as well, which may take a bit longer as I'm doing other things at the moment.

Clark

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 5771
  • Hero Points: 460
Re: Using V25 on MAC is very slow
« Reply #23 on: January 13, 2021, 07:31:02 pm »
These changes were night and day for me. Did you accidentally turn off the "Delayed Minimap Updating for Faster Scrolling" setting? We may need to remove support for this for macOS. Using this setting for any other platform does not destroy scrolling performance.
« Last Edit: January 13, 2021, 07:58:20 pm by Clark »

nunya

  • Community Member
  • Posts: 10
  • Hero Points: 0
Re: Using V25 on MAC is very slow
« Reply #24 on: January 13, 2021, 08:07:01 pm »
Did you accidentally turn off the "Delayed Minimap Updating for Faster Scrolling" setting?

I think so. I'm not really sure how that turned off, as I don't ever recall touching it from the GUI.