Author Topic: Documents->Uncomment Lines can not work  (Read 283 times)

ahkevin

  • Community Member
  • Posts: 14
  • Hero Points: 0
Documents->Uncomment Lines can not work
« on: April 15, 2021, 04:01:42 am »
When I use Documents->Uncomment Lines, it just uncomment the first line.

OS: Windows 10 x64
SlickEdit Pro 2020 (v25.0.1.0 64-bit)  with  hotfix_se2501_6_cumulative.zip (Revision: 6)

Dennis

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 3231
  • Hero Points: 459
Re: Documents->Uncomment Lines can not work
« Reply #1 on: April 15, 2021, 02:20:05 pm »
If you want to uncomment a block of line comments, you will need to select it first.

I agree that the name "Uncomment Lines" (plural) is misleading, and perhaps Uncomment Lines should do more if there is no selection.  I will file a future feature request for us to re-address that.

ahkevin

  • Community Member
  • Posts: 14
  • Hero Points: 0
Re: Documents->Uncomment Lines can not work
« Reply #2 on: April 16, 2021, 02:43:53 am »
Yes, I select lines all, but only uncomment first line.
I remember V25.0.0.0 not having this problem.

Dennis

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 3231
  • Hero Points: 459
Re: Documents->Uncomment Lines can not work
« Reply #3 on: April 16, 2021, 02:07:17 pm »
You'll have to provide an example, maybe this is language specific.

ahkevin

  • Community Member
  • Posts: 14
  • Hero Points: 0
Re: Documents->Uncomment Lines can not work
« Reply #4 on: April 19, 2021, 03:28:23 am »
C language.
Please look at the video in attachments.

Dennis

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 3231
  • Hero Points: 459
Re: Documents->Uncomment Lines can not work
« Reply #5 on: April 19, 2021, 02:15:56 pm »
I see what is happening in the video, but I can not reproduce that.  I guess this has to do with your configuration settings.  What editor key emulation are you using?

Does this still happen to you if you start the editor in a default configuration?

   [installation_path]\win\vs.exe +new -sc C:\temp\defcon1\

Try opening the Sample C++ project, select lines, and comment / uncomment.

ahkevin

  • Community Member
  • Posts: 14
  • Hero Points: 0
Re: Documents->Uncomment Lines can not work
« Reply #6 on: April 20, 2021, 02:39:53 am »
I use VIM emulation. it works in default configuration.
Maybe my configuration was somethings wrong.

Dennis

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 3231
  • Hero Points: 459
Re: Documents->Uncomment Lines can not work
« Reply #7 on: April 20, 2021, 03:16:09 pm »
Attach your user.cfg.xml from your SlickEdit configuration directory and I'll try to reproduce the issue.