Author Topic: Options in Linux VM, Apply button off-screen  (Read 160 times)

JimmieC

  • Senior Community Member
  • Posts: 468
  • Hero Points: 16
Options in Linux VM, Apply button off-screen
« on: May 05, 2021, 03:37:35 pm »
I am running SE in a Linux VM. Many of the "Options" dialog have the the "Apply" buttons and other buttons off the bottom of the screen. One example is C\C++ Context Tagging. When I go to the top edge of the options page, the cursor changes to indicate that I  could resize the dialog. However, it cannot be resized.

See attached image.

Clark

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 5777
  • Hero Points: 461
Re: Options in Linux VM, Apply button off-screen
« Reply #1 on: May 05, 2021, 07:41:26 pm »
There are displays that are too small for SlickEdit to handle. More resize or scrolling capabilities would be nice for some of the larger dialogs. You might be able to make the dialog font size smaller but you have to have good eyes for that.

JimmieC

  • Senior Community Member
  • Posts: 468
  • Hero Points: 16
Re: Options in Linux VM, Apply button off-screen
« Reply #2 on: May 05, 2021, 08:17:56 pm »
My display is 1920x1080. A little bit of that is used by the VM frame unless operated in Full-Screen. Also, I don't Auto-Hide the taskbar so some vertical space is used there as well.

So, it seems that many of the Options dialog on default font requires the full 1080 (minus the taskbar). With virtualization more popular, that might be a little greedy. I tried Full-Screen mode for the VM but that didn't fix it.

I changed the dialog font from 10 to 9. That fixed it (although I haven't tried every Options dialog). I think the C\C++ Context Tagging is among the tallest though.

Clark

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 5777
  • Hero Points: 461
Re: Options in Linux VM, Apply button off-screen
« Reply #3 on: May 05, 2021, 08:50:32 pm »
1920x1080 is usually plenty big enough. However, Linux seems to have problems with DPI. SlickEdit may be scaling due to the DPI which we've found on Linux can be way off. Reducing the dialog font is a good work around.