Author Topic: "Ctrl+." Problem ???  (Read 6282 times)

mychong

  • Community Member
  • Posts: 46
  • Hero Points: 0
"Ctrl+." Problem ???
« on: July 16, 2007, 03:43:05 am »
Found something strange with SE v12.0.2.  Some times, when "Ctrl+." (Go to Definition Of ...) on a symbol, only the corresponding header files are shown, but not the C++ source file with the function definition.

Can someone please confirm this?

-------------------------------------------
SlickEdit Version 12.0.2.0

Serial number: WLxxxxxx
Licensed number of users: Single user

Build Date: July 02, 2007
Emulation: CUA

OS: Linux
OS Version: Fedora Core release 1 (Yarrow)
Kernel Level: 2.4.22-1.2115.nptl
Build Version: #1 Wed Oct 29 15:42:51 EST 2003
X Server Vendor: The XFree86 Project, Inc

Installation Directory: /opt/slickedit/
Configuration Directory: /home/mychong/.slickedit/12.0.2/

mychong

  • Community Member
  • Posts: 46
  • Hero Points: 0
Re: "Ctrl+." Problem ???
« Reply #1 on: July 19, 2007, 12:10:31 am »
Can SlickEdit Team comment/advise? Please? ???

Kohei

  • Senior Community Member
  • Posts: 192
  • Hero Points: 25
Re: "Ctrl+." Problem ???
« Reply #2 on: July 19, 2007, 12:35:53 am »
The best way to proceed with the problem you are experiencing is to try to create a minimalistic sample project that replicates your problem, and send it to SlickEdit Support.  I recommend that because sometimes it's hard to second-guess what the problem might be without looking at your source files, even by the SlickTeam or some of the power users here in this forum.  Your case is probably one of those hard-to-guess ones.

Having said that, I've noticed a slight tagging behavior change from 12.0.1 to 12.0.2, w.r.t. the handling of "using namespace" statements.  I'm not sure this is related to your problem, but does your C++ source file have one or more "using namespace" statements?

Kohei
« Last Edit: July 19, 2007, 12:49:04 am by Kohei »

mychong

  • Community Member
  • Posts: 46
  • Hero Points: 0
Re: "Ctrl+." Problem ???
« Reply #3 on: July 19, 2007, 01:24:58 pm »
Yes, I do have 'using namespace' statements in most of my source files. Thanks for your advice. Is there any fix for this 'namespace' related problem?

I just downloaded "hotfix_se1202_cumulative.zip" (Revision 3, Updated on 07-18-2007). Yet to see whether this problem has been taken care of.

Is there any SlickEdit Team members regularly monitoring this forum?  If they do, they should be able to provide a better support to their customers. I do not understand why I need to pay for the maintenance if I cannot get good support!!!

Rodney

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 682
  • Hero Points: 43
Re: "Ctrl+." Problem ???
« Reply #4 on: July 19, 2007, 01:45:57 pm »
Kohei is correct. We need an example of what you are talking about. While a Maintenance contract entitles you to access to our Support staff, they will always accept bug reports. Please send support@slickedit.com a minimal example of what you are talking about or post an example to this forum.

Thanks.

--rodney

SlickEdit Support

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 236
  • Hero Points: 22
Re: "Ctrl+." Problem ???
« Reply #5 on: July 19, 2007, 03:31:01 pm »
Hello All,
 
From the SlickEdit Community Forum "Welcome" sticky:  Welcome to the SlickEdit product forum. This is a great place for SlickEdit users to assist each other by asking questions, discussing product issues, and voicing opinions. Although our staff will monitor the forums and answer selected questions, it is not our intent to address support requests from within the forum.

If you have a query/topic that falls under your expectations of your SlickEdit Maintenance and Support Agreement, please send any and all pertinent information to support@slickedit.com
 
Also, as a courtesy, if you post a topic/comment to the Community site and email the SlickEdit Support Team about the same topic, please let your Community peers know that you have contacted SlickEdit Support about this topic, and also let SlickEdit Support know that you've posted on Community.  (Even if the topic does not fall under the terms of a Maintenance and Support agreement, a SlickEdit Team Member may be able to help you and your fellow Users.)
 
Best,
SlickEdit Product Support

mychong

  • Community Member
  • Posts: 46
  • Hero Points: 0
Re: "Ctrl+." Problem ???
« Reply #6 on: July 20, 2007, 06:46:58 am »
Look like Kohei is right about the "using namespace" problem. Everything just worked fine as before (prior to v12.0.2) if I removed the "using namesapce" statements from my .c++ source files. Kohei deserved 1 Hero Point, at least. :)

Would very much appreciated if SlickEdit Team could look into this matter and provide a hot fix ASAP. It's disturbing!

Thanks,
« Last Edit: July 20, 2007, 06:50:07 am by mychong »

Kohei

  • Senior Community Member
  • Posts: 192
  • Hero Points: 25
Re: "Ctrl+." Problem ???
« Reply #7 on: September 14, 2007, 02:04:10 pm »
As far as I'm concerned, this problem is fixed in 12.0.3.  I use that version, and I don't see this problem any more.

Kohei