Author Topic: I've got to get this autoraising fixed  (Read 406 times)

rwuest

  • Community Member
  • Posts: 16
  • Hero Points: 0
I've got to get this autoraising fixed
« on: June 29, 2021, 02:02:25 pm »
I finally upgraded from V19 to V25 a few weeks ago.  I have the latest: V25.0.2.0. It comes with a new "feature" I find quite annoying: VS autoraises it's window on it's own when I move the mouse into it.  Very annoying to have whatever you are reading covered by VS just because you moved the mouse around the screen.  This is a new "feature" as V19 definitely does not do it. I kept it installed and have tried it.

I have an fairly old Linux install: Fedora release 20 (Heisenbug).  My window manager is xfce.  I have autoraise disabled (no other window auto raises so the window manager is doing the right thing) and I have focus follows mouse on, which also works just fine in every other application without raising any windows when I mouse over them and type.  I have carefully gone through every relevant page of the VS options and there is nothing I can find that controls this (why would anyone want the app to autoraise itself anyway?  That's what window managers are for: to manage windows.).   Any help would be greatly appreciated.

Dennis

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 3401
  • Hero Points: 465
Re: I've got to get this autoraising fixed
« Reply #1 on: June 29, 2021, 03:46:59 pm »
Go to Tools > Options... > Appearance > Tool Window and Toolbar Options.

Under the "Tool Windows" group, there is a checkbox:  "
  • Auto show tool window on mouse over", uncheck it.

rwuest

  • Community Member
  • Posts: 16
  • Hero Points: 0
Re: I've got to get this autoraising fixed
« Reply #2 on: June 29, 2021, 04:24:45 pm »
It is already unchecked.

Dennis

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 3401
  • Hero Points: 465
Re: I've got to get this autoraising fixed
« Reply #3 on: June 29, 2021, 04:48:51 pm »
Sorry, I should have read your post more closely.  I believe it is the "focus follows mouse" causing this.  Patrick will probably want to chime in at this point, I'm not sure there is a way around this because Qt4 treats the focus in event much like an application activate event.

rwuest

  • Community Member
  • Posts: 16
  • Hero Points: 0
Re: I've got to get this autoraising fixed
« Reply #4 on: June 29, 2021, 05:23:40 pm »
I have several QT4 applications that do not act this way (I have Qt 2, 3, 4 and 5 on here and apps in all of them) so I don't believe it is inherent in QT to do this.  As I said before, autoraising should be a function of the window manager, not the apps.  What was VS19 written in?  It doesn't autoraise.

rwuest

  • Community Member
  • Posts: 16
  • Hero Points: 0
Re: I've got to get this autoraising fixed
« Reply #5 on: June 29, 2021, 06:11:54 pm »
Just for grins, I fired up QT4's qdevelop.  It tells me it is running QT4.  It behaves properly, i.e., when I mouse over it, it does not autoraise itself and I can still type into it without it being the topmost window (focus follows mouse works correctly). If I click in it, it raises.  Just like it should.

patrick

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 1591
  • Hero Points: 140
Re: I've got to get this autoraising fixed
« Reply #6 on: June 29, 2021, 08:43:19 pm »
I don't think there's anything I can add without trying it out on XFCE and see what's going on.  Off the top of my head, I'm not sure why we'd request a raise for focus-in.   I'll put that next on my list. 


patrick

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 1591
  • Hero Points: 140
Re: I've got to get this autoraising fixed
« Reply #7 on: June 30, 2021, 08:13:45 pm »
Oddly enough, I haven't been able to reproduce that.  For an initial test I went with XFCE 4.14 because I had it at hand.  Changed the Settings > Window Manager > Focus > "Focus model" to follows mouse, and left "Raise on focus" off.   I played around with different configurations, with docked/undocked tool and editor windows, but it got the focus without the window raising.

Can you post the user.cfg.xml and vrestore.slk files from your configuration directory?  (default location: $HOME/.slickedit/25.0.2)  It's possible some setting I haven't considered is changing the behavior.  The vrestore.slk has window layout information in case that is playing a part.

What version of XFCE do you have installed?  I really don't expect a difference, but I'll have to check if nothing else pans out.


Dennis

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 3401
  • Hero Points: 465
Re: I've got to get this autoraising fixed
« Reply #8 on: June 30, 2021, 08:25:57 pm »
@rwuest:  What part of SlickEdit are you moving the mouse over when it raises? 

Menu bar? 
Editor window?
Tool window (like Defs tab)?
A hidden tool window docking area?
A toolbar?
A floating tool window?
A floating MDI area (torn-out editor window)?
The command line or status area?

If it is a tool window or a toolbar, which one specifically?

If it is an editor window, what components does the mouse pass over on the way to the editor window.

Do you have the Preview window docked or auto-hidden?

rwuest

  • Community Member
  • Posts: 16
  • Hero Points: 0
Re: I've got to get this autoraising fixed
« Reply #9 on: June 30, 2021, 09:03:22 pm »
@Dennis it does not matter.  In the window, in decorations, buttons, title bar, etc.  It happens everywhere.

rwuest

  • Community Member
  • Posts: 16
  • Hero Points: 0
Re: I've got to get this autoraising fixed
« Reply #10 on: June 30, 2021, 09:12:52 pm »
@patrick: I have version 4.10.1-4.fc20.x86_64
Requested files attached.
One other thing I did: I selected the "Activate focus stealing prevention" button in my Window Manager Tweaks tool (under the Focus tab).  It did have the affect of preventing VS from autoraising.  Unfortunately, it had the affect of making my WM toolbar not work right and I couldn't select any windows properly.  basically, it breaks the WM so I have no idea what it is really used for.

patrick

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 1591
  • Hero Points: 140
Re: I've got to get this autoraising fixed
« Reply #11 on: June 30, 2021, 09:22:08 pm »
re: focus stealing. Interesting, I had turned that on and off in the WM tweaks to be paranoid, but it didn't make any difference for me.  The focus stealing prevention should usually only take effect on new windows from an existing client, so I'm not sure how that comes into play.

Thanks for the files, I'll check it out with those.

patrick

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 1591
  • Hero Points: 140
Re: I've got to get this autoraising fixed
« Reply #12 on: July 01, 2021, 04:06:38 pm »
Just a quick update, I can reproduce it with your configuration.  So I've got something to work with.  Very odd behavior, I can see a delay between the time SlickEdit gets focus, and the time it raises. 

patrick

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 1591
  • Hero Points: 140
Re: I've got to get this autoraising fixed
« Reply #13 on: July 01, 2021, 04:38:31 pm »
As a temporary workaround, go to Tools > Options > Appearance > Tool Window & Toolbar Options, and uncheck "Hide when application is inactive" in the "Tool Windows" and "Toolbars" groups.

This option doesn't seem to be in v19.  It causes the raise even if there are no tool windows/bars pulled out of the main window, which doesn't seem right.  So I'll start looking at that. 

rwuest

  • Community Member
  • Posts: 16
  • Hero Points: 0
Re: I've got to get this autoraising fixed
« Reply #14 on: July 01, 2021, 04:59:57 pm »
Oh my.  That does it.  I honestly thought I had tried that.  I thought I had tried everything.

Work around or not, it seems to reign this raising business in, so thank you!