Author Topic: symbol coloring bug in v26 beta1  (Read 711 times)

ahkevin

  • Community Member
  • Posts: 35
  • Hero Points: 0
Re: symbol coloring bug in v26 beta1
« Reply #15 on: August 11, 2021, 03:45:55 am »
@rp:  Could you post your user.cfg.xml from your 25.0.2 configuration directory here.  Just attach it.  There's nothing private in it.  It's XML, you can look though it yourself.

@kevin:  Thanks, did you also migrate your configuration by exporting form 25.0.2 and importing into 26.0.0?
yes

ahkevin

  • Community Member
  • Posts: 35
  • Hero Points: 0
Re: symbol coloring bug in v26 beta1
« Reply #16 on: August 11, 2021, 03:47:13 am »
@rp:  That user.cfg.xml did not contain any symbol coloring customizations.

Some of the built-in symbol coloring rules and colors were modified in the new release, trying to improve the color choices and adding a couple new symbol coloring rules.  I do not know if this is the difference you are seeing, please give me an example.

@kevin: I tested exporting your settings form 25.0.2 and importing them into a clean 26.0.0, I still can not reproduce what you saw.
ok, thanks, i will test again.

Dennis

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 3467
  • Hero Points: 466
Re: symbol coloring bug in v26 beta1
« Reply #17 on: August 11, 2021, 07:30:56 pm »
@rp: 

I am attaching a set of options to load with a new Default color profile, that matches the symbol coloring colors from 25.0.2 better.  In Beta3, the Default color profile will use these colors.

Also for Beta3, I am adding a new color profile named "Natural", which will be identical to "Default", but use the more natural symbol coloring choices that I initially had adopted for version 26.  I say natural here because the choices try to mirror the color choices for the symbol icons (variables green, functions magenta, etc).  You probably won't want the "Natural" scheme -- I just wanted to explain the reasoning behind those color choices, as they are used in numerous other color profiles.

Dennis

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 3467
  • Hero Points: 466
Re: symbol coloring bug in v26 beta1
« Reply #18 on: August 11, 2021, 07:32:07 pm »
Forgot the attachment.  Doh!

rjpontefract

  • Senior Community Member
  • Posts: 143
  • Hero Points: 7
Re: symbol coloring bug in v26 beta1
« Reply #19 on: August 11, 2021, 08:13:55 pm »
Hi Dennis, that's fantastic, thanks  :D