SlickEdit Product Discussion > SlickEdit User Macros

xretrace and xxutils V2.20 / includes plugins for slick V26

(1/6) > >>

I've updated xretrace and xxutils, a few minor fixes and some extra things.  For xretrace there is a new checkbox in the settings dialog called "don't touch line modify flags".  xretrace tries to track modified lines but it clears the "line modify" flag to keep track of the order of changes.  If you use "colour modified lines" you might not like this.  If you set "don't touch line modify flags" it won't interfere with the "line modify" flags but will still track modified lines, just not always with the correct order.

For slick V26 and later, xretrace and xxutils are supplied as plugins - and which are installed using the plugin-install command. 

For slick V25 and earlier there is a zip file ( which you unzip into your configuration folder which will create a UserMacros folder containing an xretrace folder containing the source files and help file pdf.  You must then load firstly xretrace.e then xxutils.e.

Please read the help file for more installation information - page 1 for xretrace, page 12 for xxutils installation.  If you've been using xretrace prior to September 2021 then the location of the xretrace source files is changing and you need to unload some modules before loading the new ones.  See the help file.

These modules have been tested for slick V20 up to V26.

The zip file (and github) includes a help file (attached) xretrace-xxutils-help.pdf plus the OneNote notebook used to create it. 

For github, see the xretrace folder here, it has everything the zip file does
The tag is

For xxutils, all of the commands now have a prefix of user_graeme_ to ensure they are unique.  If you don't want the prefix, you can change these
#define XUN(a) user_graeme_##a
#define XUNS "user_graeme_"
to this
#define XUN(a) a
#define XUNS

Thanks so much Graeme for this update.

I installed it (using today's github) in beta3 by loading 'xload-macros.e' and got an error message, but it seemed to load, see attached screenshot.

I have yet to use it, if there are problems I will post again.

xretrace seems to be working for me.

Today I shut down SE (had to kill it, but not kill -9) and restarted SlickEdit.

Now I am getting 4 dialogs of questions whenever I start SE. I attached screenshots.

Is this normal/expected? Would rather not have to do this every time I run SE.

I then shut down SE normally and restarted and every time I am asked these 4 dialogs.

I also tried 'xtrace-disable', but still when I restart SE I get these 4 dialogs.

Nope, not expected.  It means that slick is trying to load xload-macros.e every time it starts up - don't know why it would do that.  You can probably fix by using macro -> unload module on xload-macros.e.

This might be a V26 issue.  For V26 I was planning to support only the plugin build but I'll check it out.
I'm probably changing this mechanism anyway.  Sorry about that.

--- Code: ---definit()
   if (arg(1)=="L") {
      // If this is NOT an editor invocation

      int res = _message_box('Load xretrace & xxutils ?' \n \n 'If you are installing a SlickEdit upgrade, you should select NO here.', '', MB_YESNO);
      if (res != IDNO) {
         if ( !load_error && find_index('xretrace_show_control_panel', COMMAND_TYPE) != 0 ) {
            _message_box( 'xretrace has been successfully loaded.' \n \n:+
                          'Use the "xretrace_options" command to set xretrace options.' \n \n :+
                               'Uncheck "retrace delayed start" for normal operation.');
         _message_box('Use the load_xretrace_modules command to load xretrace at any time.');

--- End code ---

Hi Rob

I can't reproduce the problem using beta 3.  The definit in xload-macros.e should do nothing for a normal startup so slickedit must be trying to rebuild it every time.  It might do that if the .ex file is out of date.  You might be able to fix it by manually reloading xload-macros.e and let it build xretrace.

Is it possible the problem you have was caused by the crash?  Had you been restarting slickedit without a problem before the crash.  Also I haven't done any testing on Linux so far.

I did find another problem though - xretrace won't start running unless I call init-xretrace twice at startup.  For some reason the timer callback dies the first time.  Could be a bug in slickedit I guess.  That's with the xretrace github code though, I've made a few changes since then.


[0] Message Index

[#] Next page

Go to full version