Author Topic: clipboard problem under linux  (Read 2589 times)

doberino

  • New Community Member
  • Posts: 1
  • Hero Points: 0
clipboard problem under linux
« on: July 18, 2007, 12:38:16 pm »
hi everybody

I'm using SlickEdit 12.0.1.0 under Linux with a remote X/Server under WinXP using X/cygwin (tried XMing as well). Unfortunately, copying between SlickEdit and other applications (under Linux or windows) doesn't work reliably. When I start slickEdit, it works a few times and suddenly no copying/pasting from/to other applications is possible anymore -- luckily, I can still copy/paste text within slickEdit.

If I copy some text from another Linux application e.g. a shell I can paste it in WinXP and vice versa. This makes me think that it's not a remote-X problem but a problem with the way slickEdit handles its clipboard(s) under Linux.
Sometimes when I open the clipboard window (shift+ctrl+v), the latest entry is copied into the OS buffer and available in other applications...

Any hints? I checked all other entries regarding clipboard problems: they all seem to have been fixed with release 11

Best regards

Rodney

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 706
  • Hero Points: 45
Re: clipboard problem under linux
« Reply #1 on: July 19, 2007, 03:32:53 pm »
I am not sure what the problem is. Some simple things to check (you are probably doing all of these things already, but I have to be sure):

1. Make sure you are using the system clipboard when copy/paste between applications. This means using the middle mouse button to paste, and select-and-leave-selected to get a selection onto the system clipboard.

2. Make sure that MButtonDn (the middle mouse button) is bound to mou_paste within SlickEdit (Tools>Options>Key Bindings, Search by key sequence).

3. Make sure "Mouse selection creates clipboard" is ON (Tools>Options>General, Selections).

If none of that sheds any light on the problem, then send support@slickedit.com an email and reference this forum thread.

--rodney

jbhurst

  • Senior Community Member
  • Posts: 406
  • Hero Points: 33
Re: clipboard problem under linux
« Reply #2 on: July 19, 2007, 08:20:10 pm »
Hi,

It seems there are some circumstance in which SlickEdit's clipboard gets corrupted:

http://community.slickedit.com/index.php?topic=776.0

You could try reloading clipbd.e (in your supplied macro source directory).

Regards

John Hurst
Wellington, New Zealand