Author Topic: Globally turn off line indent  (Read 232 times)

scottm@interprose.com

  • Junior Community Member
  • Posts: 4
  • Hero Points: 0
Globally turn off line indent
« on: September 21, 2021, 09:06:03 pm »
Hi My name is Scott and I'm new to SlickEdit. I'm trying to find out how to turn off Line Indent globally. Any help would be greatly appreciated. Thanks!

Graeme

  • Senior Community Member
  • Posts: 2675
  • Hero Points: 334
Re: Globally turn off line indent
« Reply #1 on: September 22, 2021, 02:32:23 am »
Hi Scott
Can you give a specific example that shows exactly where you're seeing an indent that you don't want and what language you're using?  Also what edition and version of slick are you using?

In tools -> options -> languages -> all languages, you can set options that will be applied to every language  - if you set an option, that same option gets set individually in all languages.  It appears that if you then clear the global option, the individual language options do not all get cleared - actually I'm not sure what the strategy is, the individual ones do sometimes get cleared.
 

scottm@interprose.com

  • Junior Community Member
  • Posts: 4
  • Hero Points: 0
Re: Globally turn off line indent
« Reply #2 on: September 22, 2021, 09:24:08 pm »
*
line1
  line2

I type line1 and hit enter, the cursor goes back to pos1 (for lack of a better term).
Then I hit 2 spaces and type line2 and hit enter. Instead of the cursor going to pos1 again, it lines up under the l in line2. Hope that makes sense!

Graeme

  • Senior Community Member
  • Posts: 2675
  • Hero Points: 334
Re: Globally turn off line indent
« Reply #3 on: September 22, 2021, 10:42:07 pm »
Hi Scott

The behaviour depends on the type of file.  Could you try answering the questions that I asked.

What language mode/ file extension you're using?  Also what edition and version of slick are you using?

You can see the language mode in the Document menu beside and below "select mode".


scottm@interprose.com

  • Junior Community Member
  • Posts: 4
  • Hero Points: 0
Re: Globally turn off line indent
« Reply #4 on: September 23, 2021, 08:29:03 pm »
Sorry. Under Language Mode it says Plain Text. I'm running Slick Edit Standard 2020 (V 25.0.2.0 64 Bit).
I'm programming for a PICK system. The Language is PICK Basic. Thanks again!

Graeme

  • Senior Community Member
  • Posts: 2675
  • Hero Points: 334
Re: Globally turn off line indent
« Reply #5 on: September 24, 2021, 12:04:04 am »
You should probably map your file extension to "visual basic".  In tools -> options -> languages -> file extension manager.  A file extension of "bas" by default maps to visual basic so presumably your file extension is not bas.

Does indenting sometimes determine the control flow like it does in Python  - i.e. correct indenting is extremely important?  According to this website it might
https://en.wikibooks.org/wiki/BASIC_Programming/Beginning_BASIC/Control_Structures/IF...THEN...ELSEIF...ELSE

How is slickedit to know whether you want multiple lines to be indented or just one line?


scottm@interprose.com

  • Junior Community Member
  • Posts: 4
  • Hero Points: 0
Re: Globally turn off line indent
« Reply #6 on: September 24, 2021, 02:26:07 pm »
You're correct. I'm using txt as the extension. I'll try using bas instead. Thanks again!