SlickEdit Product Discussion > SlickEdit®

Globally turn off line indent

(1/2) > >>

scottm@interprose.com:
Hi My name is Scott and I'm new to SlickEdit. I'm trying to find out how to turn off Line Indent globally. Any help would be greatly appreciated. Thanks!

Graeme:
Hi Scott
Can you give a specific example that shows exactly where you're seeing an indent that you don't want and what language you're using?  Also what edition and version of slick are you using?

In tools -> options -> languages -> all languages, you can set options that will be applied to every language  - if you set an option, that same option gets set individually in all languages.  It appears that if you then clear the global option, the individual language options do not all get cleared - actually I'm not sure what the strategy is, the individual ones do sometimes get cleared.
 

scottm@interprose.com:
*
line1
  line2

I type line1 and hit enter, the cursor goes back to pos1 (for lack of a better term).
Then I hit 2 spaces and type line2 and hit enter. Instead of the cursor going to pos1 again, it lines up under the l in line2. Hope that makes sense!

Graeme:
Hi Scott

The behaviour depends on the type of file.  Could you try answering the questions that I asked.

What language mode/ file extension you're using?  Also what edition and version of slick are you using?

You can see the language mode in the Document menu beside and below "select mode".

scottm@interprose.com:
Sorry. Under Language Mode it says Plain Text. I'm running Slick Edit Standard 2020 (V 25.0.2.0 64 Bit).
I'm programming for a PICK system. The Language is PICK Basic. Thanks again!

Navigation

[0] Message Index

[#] Next page

Go to full version