Author Topic: A question about plugin on v25.0.2.0 + MacOS  (Read 168 times)

suntu

  • Junior Community Member
  • Posts: 3
  • Hero Points: 0
A question about plugin on v25.0.2.0 + MacOS
« on: October 13, 2021, 05:51:06 am »
Hi,
sorry for bothering. I'm new to Slickedit and want to try out the plugin from this link
https://community.slickedit.com/index.php?topic=17824.0#top

I'm now using slickedit v25.0.2.0 on Mac OS. when I run command plugin-install it pops a windows to let me open file, but it cannot recognize that user_jporkkatc.symhighlights.ver.2.2.zip file I downloaded from the link above. (the file name is always grey and can not be selected. I've verified that the zip file itself is good and can be unzipped successfully)

Do you have any suggestions?

Thanks a lot!

patrick

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 1651
  • Hero Points: 140
Re: A question about plugin on v25.0.2.0 + MacOS
« Reply #1 on: October 13, 2021, 12:46:04 pm »
It looks like on Mac, it defaults to *.xml for the file type for that dialog.  Run plugin-install to bring up the file chooser again, and click on the "Options" button at the bottom.  And change the Types pulldown to "Plugin Files (*.zip)".   And then you should be able to select that zip file.

Clark

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 6127
  • Hero Points: 470
Re: A question about plugin on v25.0.2.0 + MacOS
« Reply #2 on: October 13, 2021, 02:16:35 pm »
Thanks for posting

Plugin loading is broken on macOS (even if you work around open dialog issue). Works on Windows and Linux.

Built new installer for macOS to fix this for 25.0.2. 26.0.0 will need the same fixes. Will rebuild that installer very soon.

Download and install this new macOS installer

http://support.slickedit.com/outbound/2502/se_25000200_mac.dmg