Author Topic: XML Beautifier -- cannot edit tags?  (Read 195 times)

jporkkahtc

  • Senior Community Member
  • Posts: 2536
  • Hero Points: 206
  • Text
XML Beautifier -- cannot edit tags?
« on: July 08, 2022, 08:41:11 pm »
I created a new beautifier by copying an existing one.
Then I try to add new Tags.
The UI lets me add new tags and edit them.
I save and save settings.
BUG: None of the new tags are saved in user.cfg.cml.

OK, so I edit user.cfg.xml directly.
I duplicate (default tag) and change it to (MyTag)
Save.
Reload configuration.
(MyTags) appears in the UI TagSettings.
BUG: However, when I save setting, MyTags is again removed from user.cfg.xml.


It is not clear, when I add a new tag, should it be
MyTag
<MyTag>
(MyTag)
??

Clark

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 6321
  • Hero Points: 486
Re: XML Beautifier -- cannot edit tags?
« Reply #1 on: July 08, 2022, 09:22:29 pm »
Maybe the bugs are related. We will look into this.

Clark

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 6321
  • Hero Points: 486
Re: XML Beautifier -- cannot edit tags?
« Reply #2 on: July 13, 2022, 02:36:35 pm »
Here's an installer which will fix this problem (tags disappear when saved).

http://support.slickedit.com/outbound/2603/se_26000301_win64-2022-07-12.msi

This installer also a hot fix for the race condition you found.

jporkkahtc

  • Senior Community Member
  • Posts: 2536
  • Hero Points: 206
  • Text
Re: XML Beautifier -- cannot edit tags?
« Reply #3 on: July 14, 2022, 12:45:53 am »
Thanks!