Author Topic: Issues in build window after manually sshing to build machine there  (Read 7481 times)

rowbearto

  • Senior Community Member
  • Posts: 2222
  • Hero Points: 132
Re: Issues in build window after manually sshing to build machine there
« Reply #60 on: June 03, 2022, 03:29:32 pm »
FYI I'm using Patrick's commit:  https://community.slickedit.com/index.php/topic,18828.msg74731.html#msg74731 which has build date May 9, 2022.

I'm also using Qt5 version.

Maybe something with this commit makes it happen more?

Clark

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 6433
  • Hero Points: 501
Re: Issues in build window after manually sshing to build machine there
« Reply #61 on: June 03, 2022, 03:58:40 pm »
It’s just a timing dependent problem.

Clark

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 6433
  • Hero Points: 501
Re: Issues in build window after manually sshing to build machine there
« Reply #62 on: June 03, 2022, 11:40:20 pm »
Here's a new Qt5 installer of 26.0.2 with debug and the mods I thought of.

http://support.slickedit.com/outbound/2602/se_26000201_linux64qt5-2022-06-03.tar.gz


rowbearto

  • Senior Community Member
  • Posts: 2222
  • Hero Points: 132
Re: Issues in build window after manually sshing to build machine there
« Reply #63 on: June 04, 2022, 02:43:19 pm »
Thanks so much Clark! I will try it out.

Will it still fill up memory and I have to eventually exit it because consuming too much memory?

Or did you take care of that? You mentioned truncating the data in a previous post.

Clark

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 6433
  • Hero Points: 501
Re: Issues in build window after manually sshing to build machine there
« Reply #64 on: June 04, 2022, 02:56:05 pm »
There is truncation in this one. If memory gets too large let me know and I’ll truncate it more. I shouldn’t need that much history as long as you exit when you get a debug message telling you to exit because a bug was found.

rowbearto

  • Senior Community Member
  • Posts: 2222
  • Hero Points: 132
Re: Issues in build window after manually sshing to build machine there
« Reply #65 on: June 04, 2022, 11:11:55 pm »
After firing it up and doing a few builds it crashed during a next build.

Look for crash_2022_06.tar.xz on support for the core dump file and user.cfg.xml

Clark

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 6433
  • Hero Points: 501
Re: Issues in build window after manually sshing to build machine there
« Reply #66 on: June 05, 2022, 12:53:17 pm »
Messed up on truncation. Try this Qt5 installer of 26.0.2:

http://support.slickedit.com/outbound/2602/se_26000201_linux64qt5-2022-06-05.tar.gz

This installer has more truncation.


rowbearto

  • Senior Community Member
  • Posts: 2222
  • Hero Points: 132
Re: Issues in build window after manually sshing to build machine there
« Reply #67 on: June 07, 2022, 03:21:14 pm »
Unfortunately it is not reproducing :( Did you add something else besides debug, or only debug?

Clark

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 6433
  • Hero Points: 501
Re: Issues in build window after manually sshing to build machine there
« Reply #68 on: June 07, 2022, 06:17:47 pm »
Besides debug, there is an additional fix but this fix was also in the build that Patrick made for you for Python.

rowbearto

  • Senior Community Member
  • Posts: 2222
  • Hero Points: 132
Re: Issues in build window after manually sshing to build machine there
« Reply #69 on: July 13, 2022, 09:01:44 pm »
FYI: I am seeing this issue in 26.0.3.1 build date June 30. I see the <SOH> doing a  build without even sshing in.

Clark

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 6433
  • Hero Points: 501
Re: Issues in build window after manually sshing to build machine there
« Reply #70 on: July 14, 2022, 10:22:48 pm »
Here's a process buffer debug build for 26.0.3 that truncates quite a bit to reduce the size of the data:

http://support.slickedit.com/outbound/2603/se_26000301_linux64qt5-2022-07-14-process-dbg.tar.gz

I'm still hoping we get some debug data for this. With more truncation, maybe the timing won't be thrown off as much.

rowbearto

  • Senior Community Member
  • Posts: 2222
  • Hero Points: 132
Re: Issues in build window after manually sshing to build machine there
« Reply #71 on: September 22, 2022, 06:19:07 pm »
Still seeing this issue in v27 beta3. I didn't do much building in v26.0.3 past few months so not sure if I didn't catch it with the debug version due to not using it, or if it really wasn't caught with the debug version. I did start doing builds again today.

Clark

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 6433
  • Hero Points: 501
Re: Issues in build window after manually sshing to build machine there
« Reply #72 on: September 22, 2022, 06:34:46 pm »
I'll build a debug version once v27 is finished.

rowbearto

  • Senior Community Member
  • Posts: 2222
  • Hero Points: 132
Re: Issues in build window after manually sshing to build machine there
« Reply #73 on: October 01, 2022, 03:44:23 pm »
I think I start seeing this after I open the process buffer and move around in it, but I'm not sure. I haven't tried to systematically repro it this way (don't have time) but I was trying to observe what I do just before the <SOH> start coming out. I typically open process buffer by executing below macro (tied to right clicking in Build tool window at the line of an error in the small build window):

Code: [Select]
// https://community.slickedit.com/index.php?topic=16731.new;topicseen#new
_command void goto_editor_window_from_build() name_info(',')
{
   int pl = p_line;
   edit ("+b  Build (.process)");
   goto_line(pl);
}

I also see that the Build Tool window menu item of "Send output to editor window" uses 'toggle-process-tab-output'

Is there any possibility that using

edit ("+b  Build (.process)");

Instead of

toggle-process-tab-output

and then jumping around in the big process buffer looking at things and searching

Could be causing these <SOH> characters to come out on the build window sometime after using the edit() function?

Note: This happens even if I never ssh into the build server first from the Build window. I've been avoiding the ssh and I still see these <SOH> in my build after a while.
« Last Edit: October 01, 2022, 03:53:50 pm by rowbearto »

rowbearto

  • Senior Community Member
  • Posts: 2222
  • Hero Points: 132
Re: Issues in build window after manually sshing to build machine there
« Reply #74 on: October 12, 2022, 08:52:37 pm »
I think this happens after I press Ctrl-End in the .process buffer while a build is ongoing. Sometimes I'm looking at one thing in the .process buffer that happened during early stages of the build and it isn't scrolling as I'm in early part of log while build is ongoing. Then when I'm done I want to see the build scrolling so I press Ctrl-End to make the buffer scroll. I do this in the process buffer editor window and in the tool window. To get the build log into the editor window I use goto_editor_window_from_build() from my last post. I have been refraining from doing Ctrl-End and I don't see these <SOH>. A short time ago I did Ctrl-End and then I did start seeing the <SOH> shortly afterwards.