Author Topic: FindInFiles: Look In <WorkSpace>  (Read 160 times)

jporkkahtc

  • Senior Community Member
  • Posts: 2428
  • Hero Points: 202
  • Text
FindInFiles: Look In <WorkSpace>
« on: November 17, 2021, 08:23:57 pm »
I've been using "<Workspace>" lately as it helps me when I alternate between multiple copies of a project.

However, when I do a FindInFiles like this there is a long delay before the search apparently starts running.
Presumably, it is iterating all the project files?

In this workspace there are several wildcard projects - a total of 2818 files.

Clark

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 6122
  • Hero Points: 470
Re: FindInFiles: Look In <WorkSpace>
« Reply #1 on: November 17, 2021, 08:57:54 pm »
Are the files remote or on your local hard disk?

jporkkahtc

  • Senior Community Member
  • Posts: 2428
  • Hero Points: 202
  • Text
Re: FindInFiles: Look In <WorkSpace>
« Reply #2 on: November 17, 2021, 11:26:38 pm »
All files are local.

Clark

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 6122
  • Hero Points: 470
Re: FindInFiles: Look In <WorkSpace>
« Reply #3 on: November 18, 2021, 12:57:04 am »
Have you set the "Tag Files Directory" for the workspace? I ask this because the wildcard cache doesn't work if you've set this. This will be fixed in 26.0.1. If you've set this I suspect this is the problem.

Post a picture of the Find in Files settings.

I tested a remote workspace with 3500 files. For me there was no delay and this remote directory is crazy slow. I only tested with one project with wildcards.

How many projects are there with wildcards? 

If you change your workspace to only contain one project with wildcards (try largest set of files), does that help much?

jporkkahtc

  • Senior Community Member
  • Posts: 2428
  • Hero Points: 202
  • Text
Re: FindInFiles: Look In <WorkSpace>
« Reply #4 on: November 19, 2021, 06:11:41 pm »
I have not set TagFilesDirectory.
There are 5 projects and all are wildcards.
There are a few randomish files too - accidentally added to some project when creating files with File->New.

FiF pauses 8 seconds after I hit "Find" before something appears to happen.
Procmon confirms - no file access during the long pause.

Find all "PerformanceProblems", "<Workspace>", "*", Exclude: "<Default Excludes>;rest2.x\"
Failed to open: C:\src\....\blah1
Failed to open: C:\src\....\blah2
Failed to open: C:\src\....\blah3
Failed to open: C:\src\....\blah4
Total found: 0     Matching files: 0     Total files searched: 2838

Clark

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 6122
  • Hero Points: 470
Re: FindInFiles: Look In <WorkSpace>
« Reply #5 on: November 19, 2021, 06:59:24 pm »
Thanks for the picture. All the time is being spent processing the excludes. I'll check if there is anything we can do to speed this up.

The work around is to remove the excludes and specify specific file extensions instead of '*'
« Last Edit: November 19, 2021, 08:51:10 pm by Clark »

Clark

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 6122
  • Hero Points: 470
Re: FindInFiles: Look In <WorkSpace>
« Reply #6 on: November 19, 2021, 09:02:13 pm »
Optimized this type of exclude processing case for 26.0.1. Should take about 1 second instead of 8.