SlickEdit Product Discussion > SlickEdit®

bug report: TAB always inserts 4 spaces in JavaScript mode (I want 3)

(1/2) > >>

jcelle:
Hello,
It looks like in JavaScript mode TAB is hard coded with length of 4.
I am attaching my settings : everything seems to be set at 3.
Despite these settings, 4 space are being inserted when I press the TAB key.
What am I missing here ?
Thanks for any advice.
Regards.

Clark:
I can't reproduce this so far.

Try a default config and then changing the indent

vs +new -sc new-config-dir

jcelle:
Hi Clark,
So this is still present in 26.0.1 (I had little hope...)
So I tried what you indicated: using the +new option was good as I went through the initial configuration wizard where I could ask TAB=3 for EVERYTHING...
Now situation in a js file is worse : TAB inserts one space !
Is there a way we could debug my actual configuration ?
*** In fact I have been able to narrow things a little bit : problem appears only within quoted strings !
Does that make sense ? Could there be another TAB behavior within quotes (single or double) ?

Thanks.

Clark:
Post a sample file as an attachment.
Post your user.cfg.xml as an attachment. That will give us your settings.
Also provide some precise steps to reproduce the problem (i.e go to line x and press Enter or Tab).

jcelle:
Sure, here we are :
Open a blank javascript file: cursor should be at line 1, column 1.
Press TAB: cursor moves to column 4 : so far so good.
Pres ENTER to go to a new line, press SPACE to position the cursor on line 2, column 2.
Press TAB.
Expected : cursor moves 3 spaces right to column 5
Seen : cursor moves to column 4 again.
I understand this can be desired to have predefined tab stops, but this is not what I want and I made my best to configure slickedit so that TAB = 3 spaces but, whether  I missed it, whether it is not possible...

Thanks for your help.
I wish you all a merry christmas.


Navigation

[0] Message Index

[#] Next page

Go to full version