SlickEdit Product Discussion > SlickEdit®

Python Live Errors stopped working after conda environment switch

(1/2) > >>

I had live errors in python working to call pylint on one conda environment - it was great. Then I had to build a new environment and switch to that, so I made all the appropriate changes in all the various dialogs (this is quite a pain, BTW. It would be nice to have python environment support like VS Code does). pylint runs fine from the command line and inside the build window. But I cannot get it to run for the live errors any more. I've tried to change it to run a script instead to see what's going on but it doesn't even seem to be doing that. I even did an upgrade to 26.0.1 (from 26.0.0) but it's still not working. Is there any way I can troubleshoot why it's not working? I've messed with all the settings I can find, creating a new live error profile, etc. Nothing seems to be working.

What platform?  64 bit windows?

One thing to try is to open up a python file, and then in a file manager or terminal go to the configuration directory (location listed in the Help -> About if you're not sure where it is).  From there, go to rte, and open up the rteout file.  Even if your script isn't being called, there may be some error output in there that can give us an idea of what's happening.

For the Options -> Language Settings -> Scripting Langages -> Python > Live Errors configuration for Python, ensure the default profile selects a profile you want, and it's not set to Auto Detect.

One other thing to check is to see if there are any Live Errors profile overrides in the project you have open.  Open up Project -> Project Properties, and go to the Live Errors tab, and see if there are any overrides for Python, and if so if they are referencing the correct profile.

If that doesn't turn up anything, I may need to send you something to enable some logging.  I do have some code for turning some of the compile time logging for Live Errors into logging that can be enabled with a setting, but it's not in the v26.0.x yet. 

Thanks for the feedback. Nothing is showing up in the rte directory which is why I'm having so much trouble. If I delete the rte folder it does seem to get re-created, but it's not copying the source file nor creating an rteout file. I've already looked at all the profile settings and there are no overrides.

The debugging I'll need to put together will need to be a exe or dll.  What platform are you on?  64 bit windows, linux, etc?

Edit: also, can you post your user.cfg.xml?  That will answer other questions I'll probably have as I get this set up.

Thanks for looking into it. I'm on 64-bit Windows 10. Config file attached.


[0] Message Index

[#] Next page

Go to full version