Author Topic: C++ compiling problem  (Read 5352 times)

Symmetric

  • Junior Community Member
  • Posts: 3
  • Hero Points: 0
C++ compiling problem
« on: July 28, 2007, 06:23:01 pm »
Hi all,

I'm having some difficulty getting Slick to compile my Visual Studio projects. When I build my project, I get a few .exe.manifest files and a couple .obj files in the Debug directory, but no .exe file is produced. The build output is as follows:

C:\Programming\C++\Game\Waves>cl @C:\DOCUME~1\PAULTI~1\LOCALS~1\Temp\3692001b6  "C:\Programming\C++\Game\Waves\Linetest.cpp"
Microsoft (R) 32-bit C/C++ Optimizing Compiler Version 14.00.50727.42 for 80x86
Copyright (C) Microsoft Corporation.  All rights reserved.

cl  /Od /W3 /Wp64 /ZI "/DWIN32" "/D_DEBUG" "/D_WINDOWS" /D_MBCS /EHsc /Gm /RTC1 /MDd /Fd"Debug/vc80.pdb" /Fo"Debug/" /c

Linetest.cpp

I don't know if there should be any further confirmation if the compile was successful.

Any help would be greatly appreciated.

Thanks,
Paul

hs2

  • Senior Community Member
  • Posts: 2738
  • Hero Points: 288
Re: C++ compiling problem
« Reply #1 on: July 28, 2007, 07:14:21 pm »
Do you get it built in VS2005 ?
If this are the final output lines of your 'Build [Solution]' the linking stage (link.exe) is missing and you won't get an executable for obvious reasons.

HS2

Symmetric

  • Junior Community Member
  • Posts: 3
  • Hero Points: 0
Re: C++ compiling problem
« Reply #2 on: July 28, 2007, 08:02:45 pm »
Yes, it builds ok in VS2005. I should correct my earlier post - the output I provided was from the build window when I run the "compile" command. The "Build" command output, straight after cleaning the solution, is this:

Microsoft (R) Visual Studio Version 8.0.50727.42.
Copyright (C) Microsoft Corp 1984-2005. All rights reserved.
------ Build started: Project: ConsoleTests, Configuration: Debug Win32 ------
Compiling...
Test.cpp
Compiling manifest to resources...
Linking...
LINK : C:\Programming\C++\Test\Debug\ConsoleTests.exe not found or not built by the last incremental link; performing full link
Embedding manifest...
Build log was saved at "file://c:\Programming\C++\Test\ConsoleTests\Debug\BuildLog.htm"
ConsoleTests - 0 error(s), 0 warning(s)
========== Build: 1 succeeded, 0 failed, 0 up-to-date, 0 skipped ==========


The exe that VS2005 produces runs as expected. No exe is generated by Slick.

Cheers,
P

hs2

  • Senior Community Member
  • Posts: 2738
  • Hero Points: 288
Re: C++ compiling problem
« Reply #3 on: July 28, 2007, 08:21:59 pm »
I'd propose to check the 'BuildLog.htm'. It provides a few more details about the things going on.
The build output clearly says that everything is fine. So the question is where the 'exe' is generated.
Strange...
HS2

Edit: In case you overlooked it: Your exe /OUT- dir differs from the output dir for the obj files etc.
« Last Edit: July 28, 2007, 08:30:58 pm by hs2 »

Symmetric

  • Junior Community Member
  • Posts: 3
  • Hero Points: 0
Re: C++ compiling problem
« Reply #4 on: July 28, 2007, 09:08:23 pm »
I probably should have mentioned, the build output is from a project I just created to debug this problem, while the first compile message is from one of my actual projects. The compile message is the same for both.

The Build Log:


Creating temporary file "c:\Programming\C++\Test\ConsoleTests\Debug\RSP00000129723456.rsp" with contents
[
/Od /D "WIN32" /D "_DEBUG" /D "_CONSOLE" /D "_UNICODE" /D "UNICODE" /Gm /EHsc /RTC1 /MDd /Fo"Debug\\" /Fd"Debug\vc80.pdb" /W3 /c /Wp64 /ZI /TP ".\Test.cpp"
]
Creating command line "cl.exe @"c:\Programming\C++\Test\ConsoleTests\Debug\RSP00000129723456.rsp" /nologo /errorReport:queue"
Creating temporary file "c:\Programming\C++\Test\ConsoleTests\Debug\TMP00000229723456.tmp" with contents
[
1 /* CREATEPROCESS_MANIFEST_RESOURCE_ID */ 24 /* RT_MANIFEST */ ".\\Debug\\ConsoleTests.exe.embed.manifest"
]
Creating command line "rc.exe /fo".\Debug\ConsoleTests.exe.embed.manifest.res" "c:\Programming\C++\Test\ConsoleTests\Debug\TMP00000229723456.tmp""
Creating temporary file "c:\Programming\C++\Test\ConsoleTests\Debug\RSP00000329723456.rsp" with contents
[
/OUT:"C:\Programming\C++\Test\Debug\ConsoleTests.exe" /INCREMENTAL /MANIFEST /MANIFESTFILE:"Debug\ConsoleTests.exe.intermediate.manifest" /DEBUG /PDB:"c:\Programming\C++\Test\debug\ConsoleTests.pdb" /SUBSYSTEM:CONSOLE /MACHINE:X86 kernel32.lib user32.lib gdi32.lib winspool.lib comdlg32.lib advapi32.lib shell32.lib ole32.lib oleaut32.lib uuid.lib odbc32.lib odbccp32.lib

".\Debug\Test.obj"

".\Debug\ConsoleTests.exe.embed.manifest.res"
]
Creating command line "link.exe @"c:\Programming\C++\Test\ConsoleTests\Debug\RSP00000329723456.rsp" /NOLOGO /ERRORREPORT:QUEUE"
Creating temporary file "c:\Programming\C++\Test\ConsoleTests\Debug\RSP00000429723456.rsp" with contents
[
/out:".\Debug\ConsoleTests.exe.embed.manifest" /notify_update /manifest

".\Debug\ConsoleTests.exe.intermediate.manifest"
]
Creating command line "mt.exe @"c:\Programming\C++\Test\ConsoleTests\Debug\RSP00000429723456.rsp" /nologo"
Creating temporary file "c:\Programming\C++\Test\ConsoleTests\Debug\BAT00000529723456.bat" with contents
[
@echo Manifest resource last updated at %TIME% on %DATE% > ".\Debug\mt.dep"
]
Creating command line """c:\Programming\C++\Test\ConsoleTests\Debug\BAT00000529723456.bat"""
Creating temporary file "c:\Programming\C++\Test\ConsoleTests\Debug\TMP00000629723456.tmp" with contents
[
1 /* CREATEPROCESS_MANIFEST_RESOURCE_ID */ 24 /* RT_MANIFEST */ ".\\Debug\\ConsoleTests.exe.embed.manifest"
]
Creating command line "rc.exe /fo".\Debug\ConsoleTests.exe.embed.manifest.res" "c:\Programming\C++\Test\ConsoleTests\Debug\TMP00000629723456.tmp""
Creating temporary file "c:\Programming\C++\Test\ConsoleTests\Debug\RSP00000729723456.rsp" with contents
[
/OUT:"C:\Programming\C++\Test\Debug\ConsoleTests.exe" /INCREMENTAL /MANIFEST /MANIFESTFILE:"Debug\ConsoleTests.exe.intermediate.manifest" /DEBUG /PDB:"c:\Programming\C++\Test\debug\ConsoleTests.pdb" /SUBSYSTEM:CONSOLE /MACHINE:X86 kernel32.lib user32.lib gdi32.lib winspool.lib comdlg32.lib advapi32.lib shell32.lib ole32.lib oleaut32.lib uuid.lib odbc32.lib odbccp32.lib

".\Debug\Test.obj"

".\Debug\ConsoleTests.exe.embed.manifest.res"
]
Creating command line "link.exe @"c:\Programming\C++\Test\ConsoleTests\Debug\RSP00000729723456.rsp" /NOLOGO /ERRORREPORT:QUEUE"

Output Window:

Compiling...
Test.cpp
Compiling manifest to resources...
Linking...
LINK : C:\Programming\C++\Test\Debug\ConsoleTests.exe not found or not built by the last incremental link; performing full link
Embedding manifest...

Does any of this look unusual?

Cheers,
P

hs2

  • Senior Community Member
  • Posts: 2738
  • Hero Points: 288
Re: C++ compiling problem
« Reply #5 on: July 28, 2007, 09:58:38 pm »
??? As far as I can see it looks ok.
Maybe the real experts can say sth. about it. Sorry - no idea.
You should keep your test solution archived - support@slickedit.com could be interested in it.
Or even better send it to them that they can have a detailed look at it.

HS2