Author Topic: Bookmark scrollbar markup not restored  (Read 252 times)

pmsteinm

  • Senior Community Member
  • Posts: 110
  • Hero Points: 3
Bookmark scrollbar markup not restored
« on: May 19, 2022, 01:22:07 pm »
I'm using 26.0.2.1 on Win11. When I add a bookmark via the bookmarks tool window I get a little green mark next to the scroll bar for the location of the bookmark (I'm referring to the one that allows you to jump position, not the blue/green mark on  the left side). If I close Slickedit and reopen it and then restore the workspace the markups are gone (although the bookmarks are still there). New bookmarks will add their marks but not the existing ones.

pmsteinm

  • Senior Community Member
  • Posts: 110
  • Hero Points: 3
Re: Bookmark scrollbar markup not restored
« Reply #1 on: May 19, 2022, 02:07:03 pm »
I just noticed that after loading the workspace if I edit the file elsewhere and reload when SlickEdit prompts me the markups are restored.

Dennis

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 3618
  • Hero Points: 481
Re: Bookmark scrollbar markup not restored
« Reply #2 on: May 19, 2022, 04:38:18 pm »
I will add this to my list to look into (maybe not this week though).

Dennis

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 3618
  • Hero Points: 481
Re: Bookmark scrollbar markup not restored
« Reply #3 on: May 20, 2022, 06:19:05 pm »
I was able to reproduce this problem in 26.0.2.  This is not a hot-fixable issue. 

However, it is behaving correctly in the development version for the next release (v27, aka SlickEdit 2022).  Somebody clever must have fixed it.

pmsteinm

  • Senior Community Member
  • Posts: 110
  • Hero Points: 3
Re: Bookmark scrollbar markup not restored
« Reply #4 on: May 20, 2022, 06:29:17 pm »
Thanks for the update.