SlickEdit Product Discussion > SlickEdit®

SlickEdit hangs up when block selecting from a large file


I have a log file containing around 100,000 lines of plain text.  There is a common prefix to every line and I am trying to select it and delete it.  I hold down the ALT key and drag and select the prefix with the mouse.  This works for some number of lines after which I am unable to alter the width of the selected text and eventually SE hangs.  I have tried this with a new configuration and it still does the same thing.

To reproduce this create a plain text file containing around 100,000 lines like this:
prefix - main content of the line

Move to the top of the file and whilst holding down the ALT key drag and select just the prefix.  Move the mouse down the screen to select just the prefix for all of the lines.  See if you can select all 100,000 without an issue.  Move your mouse down below the editor window to speed up the selection process.

As it may be important, I am running SE on Windows 10 and I am accessing the Windows machine from Microsoft Remote Desktop for Mac (over a local 1Gb/s LAN).

I can reproduce this when using the machine directly (not over RDP) but it seems to recover from the hang eventually when I do that.

I have a feeling this is something to do with too many mouse events being sent to SE and being buffered or something along those lines and SE gets overwhelmed processing them.  This might explain why it sometimes recovers if I wait long enough.

If there's anything you can do about it, I'd appreciate it.

I tried this on macOS (native desktop), and did not encounter a hang.  Maybe I'll give Windows a shot later today.

For now, let me suggest a more efficient way to select that prefix using just the keyboard.
1) Hit Ctrl+Home to go to the top of the file.
2) Hit Ctrl+B to initiate a block selection.
3) Hit Ctrl+End to move to the bottom of the file.
4) Hit Home to move to the beginning of the line.
5) Hit Cursor-right to select the prefix.

Hi Dennis
Thanks for suggesting a better way to do this. 
Can you try connecting to your Windows machine with MS Remote Desktop for Mac and try the test from there?


[0] Message Index

Go to full version