Author Topic: HEX Edition forced as a default  (Read 122 times)

unMinou

  • Junior Community Member
  • Posts: 7
  • Hero Points: 1
HEX Edition forced as a default
« on: July 28, 2022, 02:46:32 am »
I open a pds file and it opens in hex mode even though it is a text file.
I added the extension and stated that it is text.
It still open it as HEX, extremely annoying

The pds files are PALASM files for programming PAL and GALs

SLickedit version 26.0.1.0 on arch linux

Dan

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 2757
  • Hero Points: 145
Re: HEX Edition forced as a default
« Reply #1 on: July 28, 2022, 06:18:07 am »
If you open a pds file, and go to View > pds Options, is the Hex view combo box set to anything other than None?

Clark

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 6331
  • Hero Points: 486
Re: HEX Edition forced as a default
« Reply #2 on: July 29, 2022, 01:53:55 pm »
Do these files contain some binary characters? control characters 0-7. If so, SlickEdit will automatically switch to hex mode when you open the file. The work around is to either add "pds" to the list of Plain Text extensions or add a separate language setup for "pds"  (Tools>Options>Languages>Language Manager, click Add Language).