Author Topic: Update auto-complete after (ms) idle does not work Linux version  (Read 129 times)

ealbers

  • Community Member
  • Posts: 47
  • Hero Points: -6
Update auto-complete after (ms) idle does not work Linux version
« on: September 14, 2022, 03:35:58 pm »
I set the value to 4000ms to prevent the 'helpful' message from blocking my ability to read the code around where I'm typing and it still 'helpfully' pops up immediately around the cursor, helpfully blocking my ability to read the code which I'm in the middle of writing/reading/referencing.

Version: SlickEdit Pro 2021 (v26.0.3.1 64-bit Qt4)
Is there a way to move the helpful little window to somewhere else away from where I'm working/reading/writing code?  I mean auto-complete is useful SOMETIMES, just not when it pops up right over code I'm working on/referencing

Dennis

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 3725
  • Hero Points: 490
Re: Update auto-complete after (ms) idle does not work Linux version
« Reply #1 on: September 19, 2022, 06:08:15 pm »
I could not reproduce this issue with Auto-Complete, it correctly honors the settings you mentioned, however, I suspect I know what you are seeing.

The Auto-list members and Auto-list parameters features are triggered whey you type member access operators or function call operators (paren).  They do not abide by the auto-complete delay settings because they are designed to be immediate.  My guess is you want to go to Document > C/C++ Options... > Auto-Complete and turn off the two List-Symbols options near the bottom of the form.