SlickEdit Product Discussion > SlickEdit®

SE 27.0.0.6 font sizes change themselves

(1/1)

rajkej:
I'm using SE 27.0.0.6 on MAC. I am setup with multiple buffers in a single window. Many times throughout the day, my font size gets smaller without me making the change on purpose at least. I went an unbound most of the keys that change font sizes just to be sure. This morning when I opened SE, things were fine but then the preview window font size went smaller. I had two files opened and was on file A. The font size was as expected. I switched to file B, font size was proper, closed it, and when file A displayed after this, its font size was smaller. How do I help debug this?

SlickEdit Pro 2022 (v27.0.0.6)

Serial number:
Licensed number of users: Single user
License file: /Library/Application Support/SlickEdit/27/slickedit.lic

Build Date: October 17, 2022
Emulation: macOS

OS: macOS Monterey
OS Version: 12.6.1
Processor Architecture: Apple M1 Pro (10 cores)

Memory: 88% Load, 28983MB/32768MB Virtual
Shell Information: "/Applications/SlickEditPro2022.app/Contents/MacOS/secsh" -i
Screen Size: 1920 x 1080

Project Type: Cpp
Language: .py (Python)
Encoding: UTF-8, no signature

Installation Directory: /Applications/SlickEditPro2022.app/Contents/
Configuration Directory: /Users/xxx/Library/Application Support/SlickEdit/27.0.0/
Imported options from: 26.0.3.1

Dennis:
Are file1 and file2 both Unicode (or both not Unicode)?  The font configuration uses a different font for Unicode files and plain text SBCS/DBCS files (see Tools > Options > Appearance > Fonts).

I'm curious, you are using macOS emulation, most users who work with multiple buffers in a single window come from the Brief emulation world.  If you know exactly why you want that setting, that's fine, but it does make it harder for SlickEdit to handle settings that are per-window like fonts and color schemes.

To reset your font settings in all the files you currently have open:

1) Make sure you do not have per-language font settings:
    Tools > Options > Languages > All Languages > Appearance...
    If any of the font settings are set to non-default settings, click on the combo box and hit Delete to clear it back to the default.

2) Then go to Tools > Options > Appearance > Fonts... and change your font sizes to what you want, and then hit Apply.
    If the editor window font sizes are already what you want, you'll need to change them slightly, then hit Apply, then change them back and hit Apply.
    This is just to force SlickEdit to see that you changed a setting.  It will then apply the font settings to all open files.

rajkej:
All of my files are not unicode. They are stored on a remote file system.

Maybe my buffer terminology is incorrect. I started with DOS SE back in 1993 ish and have kept most of my keypresses and methodologies the same. I'm used to the macOS emulation the setting of "Multiple files share window". I switch between buffers in a window using the next-buffer/prev-buffer bound to some keys I'm used to.

I'll do the reset and see how things work.

rajkej:
After performing the reset that Dennis suggested (resetting all fonts to defaults and then setting them how I wanted them), SE has stopped changing fonts on me. To me this means that the import of settings from the previous version of SE was imperfect but at least there is a workaround. Thank you Dennis for the steps to correct this issue!

Navigation

[0] Message Index

Go to full version