SlickEdit Product Discussion > SlickEdit®

Dynamic surround with "if" need to press ESC 2 times

(1/4) > >>

I type in the following code:

--- Code: ---  if (NULL != threadName)
--- End code ---

When I'm done typing it in my cursor is to the right of 'threadName' and before the closing parenthesis.

I have to press ESC 2 times in order to get rid of the dynamic surround box. I think I should only have to press ESC one time?

Another slight annoyance, after I type "threadName" when I press the down arrow it is not expanding the dynamic surround box, instead I get the autocomplete box showing "Locals" with threadName as the only element and the down arrow moves in there. I'd rather use the down arrow to control the dynamic surround.

I'm using SE 27.0.1 on Linux x64. I have hotfix 2. I did not try with a clean config. If you can't repro with a clean config I can send my user.cfg.xml to support.

I also have horizontal dynamic surround disabled.

I tried to reproduce this, but could not.  The extra ESC may be necessary to cancel Auto-Complete, which may have came up while you were typing threadName.  First ESC would cancel Auto-Complete, second one would cancel dynamic surround.

I didn't want it to autocomplete though? I didn't press Ctrl+<space> so why is it trying to auto-complete?

Maybe you need a local variable of threadName first, such as:

--- Code: ---  const char *threadName;

  if (NULL != threadName)
--- End code ---

If you still can't repro with this then I will take some time to try and create a self contained project with my user.cfg.xml that repros it.

You can disable Auto-Complete by going to Document > C/C++ Options... > Auto-Complete > [  ] Enable auto-completion. (uncheck it)

Ctrl+Space will still work, it just won't pop up the list of completions to try to help you while you are typing an identifier.

The event tables for these features stack, since Auto-Complete comes up after Dynamic Surround in your scenario, it gets control of cursor up/down until it is done.

Thanks Dennis.

Is there a way to turn off the auto-complete from Slick-C code?

Can I turn off the auto-complete for all languages using Slick-C?


[0] Message Index

[#] Next page

Go to full version