Author Topic: Cursor drag selection runs away  (Read 288 times)

joecar

  • Senior Community Member
  • Posts: 431
  • Hero Points: 9
  • engineer/gearhead
Cursor drag selection runs away
« on: May 23, 2024, 06:48:11 PM »
When you drag the cursor to select a bunch of lines, as the cursor goes past the bottom of the SlickEdit window, the rate of line selection grows in a "runaway" manner and you lose control of the selection. The cursor then hits the end of the file (which may be quite large), and sometimes VSE hangs.

The rate of line selection should probably be slowed down, and lifting the mouse button should probably stop the rate of selection.


SlickEdit Pro 2023 (v28.0.2.0 64-bit Qt5)
« Last Edit: May 23, 2024, 10:45:31 PM by joecar »

Clark

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 6919
  • Hero Points: 531
Re: Cursor drag selection runs away
« Reply #1 on: May 23, 2024, 11:13:31 PM »
This does seem a bit fast. It is configurable but not through the GUI. Set the macro variable def_scroll_speeds

Default values are:

30.0 20.3 10.4 10.6

format is this:
Code: [Select]
delay1.skipcount1 delay2.skipcount2 delay3.skipcount3 delay4.skipcount4

Try changing it to this: 

60.0 30.3 10.4 10.6


make the delay longer and the skipcount less to slow things down.


When I lift the mouse button it does stop scrolling for me. What kind of mouse are you using?

joecar

  • Senior Community Member
  • Posts: 431
  • Hero Points: 9
  • engineer/gearhead
Re: Cursor drag selection runs away
« Reply #2 on: May 24, 2024, 04:53:55 PM »
Thanks, I will try that.

I am using the touchpad on a laptop.

joecar

  • Senior Community Member
  • Posts: 431
  • Hero Points: 9
  • engineer/gearhead
Re: Cursor drag selection runs away
« Reply #3 on: June 28, 2024, 06:08:16 PM »
This does seem a bit fast. It is configurable but not through the GUI. Set the macro variable def_scroll_speeds

Default values are:

30.0 20.3 10.4 10.6

format is this:
Code: [Select]
delay1.skipcount1 delay2.skipcount2 delay3.skipcount3 delay4.skipcount4

Try changing it to this: 

60.0 30.3 10.4 10.6


make the delay longer and the skipcount less to slow things down.


When I lift the mouse button it does stop scrolling for me. What kind of mouse are you using?
This alleviates the runaway some of the time, but it still happens.