Author Topic: How to turn off HTML auto formatting issues?  (Read 4103 times)

greggman

  • Senior Community Member
  • Posts: 277
  • Hero Points: 14
How to turn off HTML auto formatting issues?
« on: August 18, 2007, 11:18:48 pm »
I've been checking and unchecking options and so far no luck :-(

Issue #1

Code: [Select]
.code4 { color:#ff0000;background:#000080; }
.code5 {

Cursor is at the "." before "code5". I press backspace to unindent the line. Slickedit instead moves the entire line up

Code: [Select]
.code4 { color:#ff0000;background:#000080; } .code5 {

How do I get it to just do this?

Code: [Select]
.code4 { color:#ff0000;background:#000080; }
.code5 {

Issue #2

I have HTML that looks like this

Code: [Select]
<html>
<head>
<title>Some Page</title>
</head>
<body>
<style>
<style>
.pre0 { background-color: #000080; padding: 10pxdt; }
.code0 {font-family:"Terminal";font-size:10.0pt; line-height: 10pt;}
.code1 { color:#c0c0c0;background:#000080; }
.code2 { color:#ffff00;background:#000080; }
.code3 { color:#ff00ff;background:#000080; }
.code4 { color:#ff0000;background:#000080; }
.code5 { color:#ffffff;background:#000080; }
.code6 { color:#00ffff;background:#000080; }
</style>

</style>

I put the cursor on the ".pre0" line just after the last "}". I press backspace and slickedit reformats all the that to this mess

Code: [Select]
<html>
<head>
<title>c:\temp\excelreader.py</title>
</head>
<body>
<style>
.pre0 { background-color: #000080; padding: 10pxdt; .code0
{font-family:"Terminal";font-size:10.0pt; line-height: 10pt;} .code1 {
color:#c0c0c0;background:#000080; } .code2 { color:#ffff00;background:#000080; }
.code3 { color:#ff00ff;background:#000080; } .code4 {
color:#ff0000;background:#000080; } .code5 { color:#ffffff;background:#000080; }
.code6 { color:#00ffff;background:#000080; }
</style>

How do I get slickedit to just delete the "}"?  In fact if I press delete or backspace anywhere in that entire line slickedit reformats everything :-(
« Last Edit: August 18, 2007, 11:25:38 pm by greggman »

greggman

  • Senior Community Member
  • Posts: 277
  • Hero Points: 14
Re: How to turn off HTML auto formatting issues?
« Reply #1 on: August 19, 2007, 12:30:23 am »
HTML mode seems SERIOUSLY broken

I exported to HTML about 2 screens worth of python. I then loaded that HTML into slickedit. The code was something like this

Code: [Select]
<html>
<html>
<head>
<title>c:\temp\exceldump.py</title>
</head>
<body><pre>
<span class="...">...
...
about 60 lines of HTML
...
</span>
</pre>
</body>
</html>

I then copied from the first <span> line to the line. Because I missed the first
 line I had to type it by hand so I moved to the beginning of the pasted block and typed "<pre class="pre0">. I typed them all in probably under 2 seconds but then it took around 48 seconds for slickedit to enter those few characters!!!! Just trying to move the cursor around the file is painful with it sometimes taking 1 second to move 1 line.

I'm sorry to rant but I'm starting to get really upset. I upgraded to v12 a week ago and even bought maintance and I've been doing nothing but fighting with it since. I'm not trying to be mean but at the same time it's been so frustrating that I've even thought about giving up on slickedit and I've been using it since 1993!! It's really been disappointing. I upgraded because of the gracious offer to fix the perforce support so that it was on par with Visual Studio. That is turning out to have lots of issues including potentially trashing files. As I posted in another thread, indenting is no longer working correctly so I end up having to manaully indent stuff all the time to get things they way they were in v11.  v12 was the first time I've had trouble upgrading. I have 3 machines (work, home, notebook). It failed to upgrade correctly on both work and my notebook. I haven't installed it yet on my home PC (which is how I check that things worked in v11).  I already pointed out it's corrupted itself twice re-binding "}" so that it no longer works in python mode. The new buffer list is full of issues and always gets in my way instead of helping me out. The slowness that I thought I finally solved in v11 by deleting my configuration has started creeping back in v12. I'm not just talking about the HTML slowness above, I'm talking about editing C++ and sometimes having it enter about only 1 to 2 characters per second. And now, I sit down to edit some HTML and it's been 45 minutes just trying to get it to delete a character.  Right now I can't use delete or backspace. All I can do is select what I want deleted and press "cut" because otherwise it reformats my text into garbage.  :'(  (word wrap is off both in the menus and in file extension setup and comment wrap is off as well)

I hope we can find solutions to all these issues soon. For years I've been proud to point to slickedit as a productivity enhancer to my fellow programmers that think the price is high. I usually say, "a text editor is your single most used software so that price is nothing". But, with the last 2 versions, I've run into so many issues I find I hesitate to bring it up. Instead of "You should buy it" all I can really say is "it works for me" and lately even that is not true.

StephenW

  • Senior Community Member
  • Posts: 189
  • Hero Points: 21
Re: How to turn off HTML auto formatting issues?
« Reply #2 on: August 19, 2007, 09:51:11 pm »
As an interim workaround, you might like to bind a key to a macro that toggles the edit mode between fundamental and html.  This is the macro I use to set the mode:

  select_edit_mode("fundamental")

but it does not seem to be a documented macro, and I do not know what API call to use to find out and save the current mode.  Of course:

  select_edit_mode("html")

would work in this instance to get back to html mode.

David_O

  • Senior Community Member
  • Posts: 152
  • Hero Points: 8
Re: How to turn off HTML auto formatting issues?
« Reply #3 on: August 20, 2007, 01:13:32 pm »
To turn off XML/HTML formatting, go to

    Document -> XML/HTML Formatting ->

And uncheck Enable HTML Formatting.

That should take care of the first question of formatting happening when you don't want it.

As for the long delay you report later, turn off XML/HTML Formatting and see if that changes anything.  More likely there is something else going on.  If the Defs tab or Class tab is open, try closing them to see if there is a change.

Finally, send us they exact file you found the long delay for, and we'll try to recreate it.

Ian P

  • Community Member
  • Posts: 59
  • Hero Points: 2
Re: How to turn off HTML auto formatting issues?
« Reply #4 on: August 20, 2007, 07:03:54 pm »
I was having a lot of issues like that with HTML files when I first started using SlickEdit, but got things working nicely after lots of trial and error with the options. I don't have XML/HTML formatting disabled, but I can edit your example file without it screwing up the lines as you say it does. I'm not sure, but I think this is the change that I made which got things working properly:

In the Tools menu go to Options, XML/HTML formatting... Then for each of the "(default)", "(block)", tags etc. select "Preserve content" on the Content Wrap tab.

greggman

  • Senior Community Member
  • Posts: 277
  • Hero Points: 14
Re: How to turn off HTML auto formatting issues?
« Reply #5 on: August 20, 2007, 09:30:51 pm »
Thanks. The Document -> XML/HTML Formatting thing helped with the formatting issue. It didn't help with the long delays. I send in the file I was editing.