Author Topic: Typing weirdness with 12.0.3 (Linux)  (Read 13856 times)

daveallen

  • Community Member
  • Posts: 8
  • Hero Points: 0
Typing weirdness with 12.0.3 (Linux)
« on: August 25, 2007, 05:55:51 am »
I'm seeing some strange behavior while typing (first noticed in C++ files, though it also seems to happen with a new empty file).  If I type quickly enough, SlickEdit seems to see the wrong characters.  When I type "error", SlickEdit sees "erroo" (the last 'r' becomes an 'o').  When I type "there", SlickEdit sees "therr".  When I type "ActionNode", SlickEdit sees "Actionode" (the 'N' is missing).

Playing in my empty file here, it looks like whenever character n and n+2 are the same, but n+1 is different, SlickEdit uses the same character as n+1 for n+2.  I know that doesn't make a lot of sense, so here's a few examples:

  • Type "jaj" fast enough, I get "jaa"
  • Type "aba" fast enough, I get "abb"

Anyone else seeing this?  I'm fairly certain 12.0.2 didn't do this.


I guess I could also try typing slower...  :P

Ivan N. Zlatev

  • Community Member
  • Posts: 87
  • Hero Points: 5
Re: Typing weirdness with 12.0.3 (Linux)
« Reply #1 on: August 25, 2007, 07:50:20 am »
I see it. It's extremely annoying!

Steve Black

  • Community Member
  • Posts: 57
  • Hero Points: 4
Re: Typing weirdness with 12.0.3 (Linux)
« Reply #2 on: August 25, 2007, 07:29:17 pm »
not seeing it on Windows, FWIW

SlickEdit Support

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 251
  • Hero Points: 23
Re: Typing weirdness with 12.0.3 (Linux)
« Reply #3 on: August 27, 2007, 02:35:04 pm »
We're looking into this one.

i-nZ:  Can you send the info from Help-->About SlickEdit-->Program Information tab-->Copy to Clipboard to support@slickedit.com please?

Have either of you set the VSLICK_XIM env var to scim?

Thanks,
SlickEdit Support

Ivan N. Zlatev

  • Community Member
  • Posts: 87
  • Hero Points: 5
Re: Typing weirdness with 12.0.3 (Linux)
« Reply #4 on: August 27, 2007, 03:55:14 pm »
I filed a bug with support yesterday - CAS-38960 CRM:{709FAC8A-7656-46C2-902D-64901E183966}:MRC . It should include the information you are requesting.

I don't know what scim is and I do not have it installed. I haven't touched any env vars. Where can I check if VSLICK_XIM is set?

Kohei

  • Senior Community Member
  • Posts: 192
  • Hero Points: 25
Re: Typing weirdness with 12.0.3 (Linux)
« Reply #5 on: August 27, 2007, 05:43:23 pm »
Quote
Where can I check if VSLICK_XIM is set?

The easiest way (that I can think of) would be to

1. Start the shell within SE by typing start-process-window in the SE command line (hit ESC), and
2. run env within that shell window.

This will show you all the effective environment variables for the current SE process.  You should then be able to see whether or not VSLICK_XIM is set.

HTH.

Kohei

SlickEdit Support

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 251
  • Hero Points: 23
Re: Typing weirdness with 12.0.3 (Linux)
« Reply #6 on: August 27, 2007, 05:49:33 pm »
daveallen: Have you set VSLICK_XIM to scim?

i-nZ: You would have set it manually per instructions with the v12.0.3 readme; so this cancels out this possibility.

Still not repeatable on many, many environments but we'll keep trying.  Oddly, CAS-38960 contains daveallen's data; are we missing something here?

And no, we wouldn't want you to have to type/code more slowly, but until we can replicate, that may indeed be the case for now :(  We tested this with some very, very fast keystrokes to no avail.  Please send FULL OS info to support@slickedit.com if you have a moment.  (Distro, Kernel, etc.)

Thanks,
SlickEdit Support
« Last Edit: August 27, 2007, 05:53:44 pm by SlickEdit Support »

Ivan N. Zlatev

  • Community Member
  • Posts: 87
  • Hero Points: 5
Re: Typing weirdness with 12.0.3 (Linux)
« Reply #7 on: August 27, 2007, 06:28:56 pm »

i-nZ: You would have set it manually per instructions with the v12.0.3 readme; so this cancels out this possibility.

Still not repeatable on many, many environments but we'll keep trying.  Oddly, CAS-38960 contains daveallen's data; are we missing something here?

CAS-38960 is filed by me and yes I have reused parts of daveallen's description of the problem as it was clearly enough stated.

I will e-mail more information on my system right away.

Ivan N. Zlatev

  • Community Member
  • Posts: 87
  • Hero Points: 5
Re: Typing weirdness with 12.0.3 (Linux)
« Reply #8 on: August 28, 2007, 12:32:22 pm »
Just for the record, yesterday I replyed with the info to the e-mail with the generated bug number. It generated a new bug  :|. Basically you will find the requested info in CAS-38969.

SlickEdit Support

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 251
  • Hero Points: 23
Re: Typing weirdness with 12.0.3 (Linux)
« Reply #9 on: August 28, 2007, 01:17:52 pm »
Thanks i-nZ, we did receive the extra info.  We'll continue to investigate this one, and if/when we find a solution, we'll post here as well as reply to your case.

Best,
SlickEdit Support

Clark

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 3941
  • Hero Points: 256
Re: Typing weirdness with 12.0.3 (Linux)
« Reply #10 on: August 31, 2007, 02:22:56 pm »
As a work around until I fix this problem, set your XMODIFIERS environment variable to "".  This worked for one customer.  If that doesn't work, set your XMODIFIERS environment variable to @im=scim and make sure you don't set the VSLICK_XIM to scim.

I'm still investigating this problem.  I think that what is going on here is the new X input method code I added only works for SCIM.  We've been unable to reproduce this problem because we (and most customers) are using SCIM.

I'll post again once I have more information.  First I need to reproduce the problem which will probably require me to install an older version of Linux.

Ivan N. Zlatev

  • Community Member
  • Posts: 87
  • Hero Points: 5
Re: Typing weirdness with 12.0.3 (Linux)
« Reply #11 on: September 05, 2007, 11:23:04 am »
I have added unset XMODIFIERS in my ~/.bashrc and for now this seems to suppress the bug.

mtaylor

  • Junior Community Member
  • Posts: 4
  • Hero Points: 0
Re: Typing weirdness with 12.0.3 (Linux)
« Reply #12 on: September 19, 2007, 09:47:30 pm »
WOW!  I have this problem, too.  I thought I was going crazy.  This problem was happening to me and I thought that my typing skills had gone downhill.  I even removed my KVM switch because I thought that was going bad.  I'll try the workarounds to see if they help me, too.

Thanks,

Michael

Clark

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 3941
  • Hero Points: 256
Re: Typing weirdness with 12.0.3 (Linux)
« Reply #13 on: September 27, 2007, 03:37:01 pm »
I have not been able to reproduce this by trying to duplicate customers settings.  Has anyone been able to reproduce this problem in a VMWare Virtual Machine? At this point, I'm willing to try to download something huge.

The above workaround will work.

mtaylor

  • Junior Community Member
  • Posts: 4
  • Hero Points: 0
Re: Typing weirdness with 12.0.3 (Linux)
« Reply #14 on: November 28, 2007, 07:12:10 pm »
I have this problem with a fresh install of CentOS 5 and Slickedit 2007 with no configuration changes.  Have you tried it on CentOS?  I could see about making a VMware image if I can find the time at work here.