SlickEdit Product Discussion > SlickEdit®

File Tabs and Navigation Issues

(1/2) > >>

Well, I have two annoyances that I can't seem to figure out. In a previous edition of SlickEdit (which I can not remember) I had two different features at my disposal that I can not seem to figure out how to enable in my current version (10).

1) The "File Tabs" toolbar doesn't change the color of the filename to red when a buffer has been modified like it before. I can't figure out how to enable that either. I hate to admit it, but I keep forgetting to save files as a result of this. I became dependant on this and don't really want to use the Auto-Save feature.

2) When holding ctrl and hitting the up/down arrows the cursor would jump from function header to function header. Now, it does this and goes to structure defines, globals, etc. I only want it to hop to function headers / prototypes, though.

Anyone have a clue how to fix either of these annoyances? I've read all sorts of help and can't seem to figure it out for some reason. There are just so many options for so many things and I'm not finding what I need.


1. color of the 'Modified' tab refers to 'Modified Line' color set-up in 'Tools->Options->Color'
- change it, close / re-open the filetabs toolbar

2. can be solved by 'Tools->Options->Key Bindings':
a) select the 'next-tag' command and click 'Add Key...' and press ctrl-down
b) repeat a) with 'prev-tag' and ctrl-up


Close and re-open the toolbar... hmm. I never thought of trying that. I changed the color but never closed and reopened the toolbar. Dang that's simple. Doh!

Thanks for the help.  :)

Actually, now that I change the Modified Line color I still have issues with the file tabs not chaning color correctly.

When I first open SlickEdit, they won't change at all until I close and re-open the file tabs. Why would this happen? I don't have to change any settings, just close and re-open that particular toolbar.

Also, now when I undo changes / save the file, the file name stays colored as if it were modified. I tried changing the "Reset line modify" option under Tools->Options->File Options but that doesn't seem to affect it.

Any clues?


Further investigation into this issue has lead me to discover that the toolbar only seems to 'update' when I close and reopen it. So, if a file is changed when I close and reopen the toolbar, it appears in red like I want. However, if I save that file and/or undo the changes back to a unmodified state, it stays red until I once again close and reopen the toolbar. At that point, the file tabs will once again appear in the proper state until I modify the file and am required to close and reopen the toolbar.

It's almost as if the toolbar doesn't update itself at any other time than when I open it. Is there a reason for this?


[0] Message Index

[#] Next page

Go to full version