Author Topic: SlickEdit on 64bit Linux  (Read 3768 times)

mtaylor

  • Junior Community Member
  • Posts: 4
  • Hero Points: 0
SlickEdit on 64bit Linux
« on: October 16, 2007, 02:23:04 pm »
Hello,

I use openSUSE 10.3 (64bit) and SlickEdit 12.0.3.  Things work pretty well when you have the lib32 compatibility installed.  There is however one small issue that I found.  It seems that SlickEdit only looks for compilers in '/usr/lib/gcc' and not also '/usr/lib64/gcc'.  The result of this is that when you are setting up AutoTagging, it will list no C/C++ compilers in the drop down box (titled: "Create Tag Files for Run-Time Libraries") and you will have to add a compiler configuration yourself.

This could be because of different interpretations of the LSB 3.1 (I'm not sure, I haven't read the latest one).  I just wanted to bring it to anyone's attention if they were wondering why there were no compilers listed on Linux 64bit when they have them installed.

The quick fix is to create a symbolic link of the directory 'gcc' between '/usr/lib64' and '/usr/lib', i.e. "ln -s /usr/lib64/gcc /usr/lib/gcc".  Make sure that there isn't already a directory called '/usr/lib/gcc', of course.

Are there any plans at SlickEdit to fix this in a future version of SlickEdit?

-- Michael

jkwuc89

  • Senior Community Member
  • Posts: 199
  • Hero Points: 6
Re: SlickEdit on 64bit Linux
« Reply #1 on: August 20, 2009, 12:08:28 pm »
I recently installed the 64 bit edition of Ubuntu 9.04 on my HP workstation.  The only thing I had to do to get SlickEdit 12.0.3.0 to work is to install the package, ia32-libs.  Once this package and its dependent packages were installed (Synaptic Package Manager takes care of installing the dependencies automatically), SlickEdit worked normally.