Author Topic: German Umlaute in MacOS  (Read 8204 times)

Udo

  • Community Member
  • Posts: 5
  • Hero Points: 0
German Umlaute in MacOS
« on: August 08, 2006, 02:07:09 pm »
The MacOS version of SlickEdit has a problem with the German Umlauts (äöüÄÖÜ). If I press the equivalent key only a small dotted box appears. However, if I enter the <ESC> key to open the command line and then press a Umlaut key the correct character appears in the command line. Has anyone a solution to this problem?

ScottW, VP of Dev

  • Senior Community Member
  • Posts: 1471
  • Hero Points: 64
Re: German Umlaute in MacOS
« Reply #1 on: August 08, 2006, 03:38:58 pm »
It sounds like you need to change the font you are using in the editor window. The command line uses a different font by default.

Select Tools > Options > Font to bring up the Font Configuration dialog. Editor windows are controlled by the entry called "SBCS/DBCS Source Windows" or by "Unicode Source Windows", depending on the encoding you are using. The command line is controlled by an entry called "Command Line".

Try using the font used by the Command Line or try picking another font for your source windows that can produce the umlauts correctly.

--Scott

Rodney

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 774
  • Hero Points: 52
Re: German Umlaute in MacOS
« Reply #2 on: August 08, 2006, 04:39:10 pm »
Changing the font may not fix your problem. There is a known bug that can cause these characters to be botched on input. We will definitely fix this in the next patch/release. There are no great workarounds for this, other than to edit all your files as "UTF-8, no signature" (File>New and File>Open allow you to choose the encoding to use when creating/opening a file).

--rodney

Udo

  • Community Member
  • Posts: 5
  • Hero Points: 0
Re: German Umlaute in MacOS
« Reply #3 on: August 09, 2006, 02:40:25 pm »
@Rodney:

You are right. I have tried different fonts to solve the problem but no luck. Use the UTF encoding won't work for me since I am creating web pages which our server delivers as 8859-1 content. Is there any information when the patch will be released?

Rodney

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 774
  • Hero Points: 52
Re: German Umlaute in MacOS
« Reply #4 on: August 09, 2006, 09:29:04 pm »
2 ideas:

1) As originally stated: use "UTF-8, no signature" encoding when creating/opening your files. The "no signature" part guarantees that we will not attempt to save/open the file with a signature. As long as typing your umlaute characters never generates Unicode characters (i.e. only SBCS/DBCS characters are generated), then you should be fine since you end up with a file that has no Unicode characters in it.

2) Create/open your files with the "Western European (ISO-8859-1)" encoding ("Latin 9 (ISO-8859-15)" would probably work fine too).

With both of these methods, internally, these files would be opened in a window that uses the "Unicode Source Windows" font (yes, even when specifying ISO-8859-1). If this is a proportional font on your system, and you want to change it, then you can set the font from Tools>Options>Font, pick the "Unicode Source Windows" element, set your font.

--rodney

Udo

  • Community Member
  • Posts: 5
  • Hero Points: 0
Re: German Umlaute in MacOS
« Reply #5 on: August 11, 2006, 09:49:55 am »
Hello Rodney,
thank you for the prompt reply. Your solutions both work, but not if I use the "Open local files as FTP" Dialog in the FTP window. I can select "Western Europe" but the setting is ignored. However this is a big improvement for me. Thank you again for your  help.

Rodney

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 774
  • Hero Points: 52
Re: German Umlaute in MacOS
« Reply #6 on: August 11, 2006, 04:50:17 pm »
Definitely a bug and will definitely be fixed in the next patch/release (sorry, no date). In the meantime, you can load the attached hotfix macro to correct the problem with "Open Local Files as FTP".

Instructions:
1) Backup slickedit/macros/ftpopen.e
2) Copy attached ftpopen.e to same location
3) Load slickedit/macros/ftpopen.e from Macro>Load Module in SlickEdit

--rodney

Udo

  • Community Member
  • Posts: 5
  • Hero Points: 0
Re: German Umlaute in MacOS
« Reply #7 on: August 15, 2006, 06:12:00 pm »
Ah, works like a charm. Thank you very much for the hotfix.