Author Topic: Eclipse Linux plugin for 3.3  (Read 2592 times)

cdouble

  • Community Member
  • Posts: 43
  • Hero Points: 0
Eclipse Linux plugin for 3.3
« on: November 14, 2007, 02:36:31 am »
Hello,

I get the below error with the Eclipse plugin trial off the web site with Eclipse 3.3...

Error opening the editor.
An error occurred while automatically activating bundle com.slickedit.eclipse.plugin (1134).

Thanks,

CD

Ryan

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 986
  • Hero Points: 77
Re: Eclipse Linux plugin for 3.3
« Reply #1 on: November 14, 2007, 02:40:18 pm »
Hi CD,

There are a few setup issues with the plug-in on Linux that aren't a concern on Windows.  I suggest checking out LINUX_INSTALLATION_AND_STARTUP_README.pdf, which you should've been extracted when you unzipped the installer.  In a nutshell:

  • Make sure you are running with Java from Sun (or IBM)...gcj won't work.
  • If you are running with Java 5 or later, make sure you have JAVAHOME set to the root of your JDK or JRE installation
  • When you start Eclipse for the first time in any xterm, you must "source" the eclipse-se.sh script in your Eclipse directory: . /PATH/TO/ECLIPSE/eclipse/eclipse-se.sh.  This will set LD_LIBRARY_PATH so that the plug-in can load the SlickEdit libraries, and then launch Eclipse.

This takes care of 90% of the start-up problems we see on Linux.  If you continue to have issues, let me know...we will get it figured out quickly.

- Ryan