Author Topic: -# invocation option  (Read 5193 times)

yakir

  • Community Member
  • Posts: 50
  • Hero Points: 2
-# invocation option
« on: December 11, 2007, 09:24:07 am »
The -#cmd invocation option is not working.
Running 12.0.3 under Vista

e.g. vs -#end-window  doesn't

(I had it working in the past, don't know what changed :-)

yakir

  • Community Member
  • Posts: 50
  • Hero Points: 2
Re: -# invocation option
« Reply #1 on: December 11, 2007, 09:30:16 am »
OK, just after posting I got it to work.

The trick is in the syntax as follows:
"-# cmd"  (quotes included!)

Note the space between the # and the cmd  and the quotes.

SlickEdit Support

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 307
  • Hero Points: 26
Re: -# invocation option
« Reply #2 on: December 11, 2007, 06:17:10 pm »
Hello Yakir,

The SlickEdit Help on "Invocation Options" specifically points out how to handle spaces in a case such as yours:

Execute command on active buffer. For example, vs test.c -#bottom-of-buffer places the cursor at the end of test.c

Use double quotes if the command has spaces (vs test.c “-#goto-col 50“)

Best,
SlickEdit Support

yakir

  • Community Member
  • Posts: 50
  • Hero Points: 2
Re: -# invocation option
« Reply #3 on: December 13, 2007, 08:11:41 am »
My main point was that a space is REQUIRED between the  -#  and the command.

e.g.
vs "-# end-window"  works
vs -#end-window     does not work


SlickEdit Support

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 307
  • Hero Points: 26
Re: -# invocation option
« Reply #4 on: December 13, 2007, 02:30:57 pm »
Either via a Copy and Paste or with a screenshot, can you show me the _exact_ syntax that you are using from the command line?

The attached screenshot is mine, which seems to be working with SE 2007(12.0.3) on Vista.  SlickEdit is in my PATH and the readme file I am using for this test is in the temp dir that I am running the command from.

Regards,
SlickEdit Support

yakir

  • Community Member
  • Posts: 50
  • Hero Points: 2
Re: -# invocation option
« Reply #5 on: December 13, 2007, 03:41:17 pm »
SOLVED
Sorry for the false alarm
The "problem" is that I am running under 4NT and the 4NT escape character seems to have been re-set to '#'


SlickEdit Support

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 307
  • Hero Points: 26
Re: -# invocation option
« Reply #6 on: December 13, 2007, 03:48:08 pm »
Thanks for clearing that up Yakir :)

SlickEdit Support