Author Topic: How to disable jumping back of {  (Read 4278 times)

gstavi

  • Junior Community Member
  • Posts: 2
  • Hero Points: 0
How to disable jumping back of {
« on: August 16, 2006, 11:16:19 am »
I am new to slickedit. I work on C++ project on Linux.
When I try to type something like:
Code: [Select]
int foo()
    {
The parenthesis is pulled automatically to the left
Code: [Select]
int foo()
{
I scanned the options for 2 hours trying to disable this behavior but couldn't find anything that helps.

Please help.



dunkers

  • Senior Community Member
  • Posts: 631
  • Hero Points: 28
Re: How to disable jumping back of {
« Reply #1 on: August 16, 2006, 11:21:09 am »
On the Tools menu, select the "Beautify..." item and you'll be plonked into a dialog where you can set your preference (which includes not messing with braces if you don't want it to do anything at all).

Also, you can go via the File Extension Setup, make sure you're looking at the C parser, then hit the Options... button.
« Last Edit: August 16, 2006, 11:23:07 am by dunkers »

gstavi

  • Junior Community Member
  • Posts: 2
  • Hero Points: 0
Re: How to disable jumping back of {
« Reply #2 on: August 16, 2006, 11:44:41 am »
I tried in the "Beautify..." to mark the option "Do not change brace style", it seems to have no effect on my problem. Is there any other related option in this dialog?

I changed in the "C Options" dialog (File Extensions setup... -> Options...) in the "Begin-End style" tab the style to 3 which is the style I am looking for. That helped me but now if I put a brace in the beginning of the line it will be pushed forward.

What I really want is to be able to put the brace on the cursor without any auto styling and than use simple auto indenting.

Any way do do just that?


dunkers

  • Senior Community Member
  • Posts: 631
  • Hero Points: 28
Re: How to disable jumping back of {
« Reply #3 on: August 16, 2006, 12:41:54 pm »
Sorry, that was about the limit of my SlickEdit config skillz  :-[

Lee

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 1299
  • Hero Points: 130
Re: How to disable jumping back of {
« Reply #4 on: August 16, 2006, 12:58:40 pm »
From File Extensions Setup > Options...Make sure to enable "Apply to functions braces" as well as setting the brace style to style 3.