Author Topic: SFTP Tunnel  (Read 4146 times)

PHugger

  • Community Member
  • Posts: 13
  • Hero Points: 0
SFTP Tunnel
« on: January 21, 2008, 03:40:29 pm »
I'm trying to get an SSH tunnel working with vSlick.
I am successfully doing this with SQLNet and SecureCRT, but I am having problems with vSlick (SFTP).
I can connect with SFTP in vSlick directly to local servers (no tunnel) without any problems.

My tunnel is from a port on my localhost to port 22 on the target server through a gateway host.
I'm using the ssh.exe from cygwin.

The error I get from vSlick is -
Cannot initialize SFTP: Incompatible protocol version returned by server (2)

Can anyone shed any light on this problem? Even an explanation of the error message would help me figure out how I have misconfigured things on my end.

I am running an older version of vSlick, but received the same error with the latest demo version.


Thanks in advance,
PCH

PHugger

  • Community Member
  • Posts: 13
  • Hero Points: 0
Re: SFTP Tunnel
« Reply #1 on: January 21, 2008, 03:45:42 pm »
I just tried using the same SSH tunnel to connect with WS-FTP and it worked without any problems.




PCH

srouleau

  • Community Member
  • Posts: 65
  • Hero Points: 3
Re: SFTP Tunnel
« Reply #2 on: January 21, 2008, 05:49:25 pm »
Hi,

I've setup something similar recently, and turns out it was a setting on the server, not on Slick Edit, that I had to change to make it work in the end.

If I remember correctly I had to enable

PasswordAuthentication yes

in /etc/ssh/sshd_config

on the server and restart the SSH server.

Steph

PHugger

  • Community Member
  • Posts: 13
  • Hero Points: 0
Re: SFTP Tunnel
« Reply #3 on: January 21, 2008, 06:15:11 pm »
Thanks for the response. I'm not sure I can change my server..... )c8

I did find this in the FAQs though -

Question:
Why can't I SFTP using SSH public key authentication?

Answer:
SlickEdit® does not yet support SFTP public key authentication at this time. You must provide a user name and password to connect to an SFTP server.

This should be supported in the upcoming 10.0.1 patch.


Has anyone gotten this working with the current version (v12)?




PCH

Rodney

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 682
  • Hero Points: 43
Re: SFTP Tunnel
« Reply #4 on: January 21, 2008, 07:03:08 pm »
If you're getting as far as that message indicates, then the problem is exactly what the error message says. SlickEdit's SFTP support only supports SFTP protocol version 3 (this is NOT the same as the ssh protocol version). The only time I hear about this particular error message is when the user is connecting to a Solaris server. Not all Solaris servers have this problem; I suspect it may be the difference between the ssh install that Sun ships and the OpenSSH server that admins install.

I'm sorry, but there is no quick fix for this, short of having your sysadmin install the OpenSSH server. We do have this filed as a feature request.

--rodney

p.s. We have had public-key auth support for a while now.