Author Topic: GDB Problems  (Read 2770 times)

kevinelrod

  • Junior Community Member
  • Posts: 2
  • Hero Points: 0
GDB Problems
« on: February 29, 2008, 05:51:38 pm »
Hello--
I just installed SlickEdit 2007 on a Linux machine with version Red Hat Enterprise Linux AS release 4 (Nahant Update 4).  When I try to attach to a process I get two pop up windows.  One reads, "Error starting debugger : GDB has terminated prematurely" followed by another that says "Error starting debugger : GDB failed to initialize".  I know that this version of Linux is old so I built and installed the latest GDB and that didn't solve the problem.  I was previously running SlickEdit ver 11 and it worked fine.   I did a search through the community posts and the only thing I found was a post about having to install Cygwin but I assume that was referring to a version of SE for Windows.

Help!

--Kevin

kevinelrod

  • Junior Community Member
  • Posts: 2
  • Hero Points: 0
Re: GDB Problems
« Reply #1 on: February 29, 2008, 06:37:07 pm »
Okay, I fixed it.  I added a different version of gdb (6.4) and used that one instead, which works fine.

The version of GDB that doesn't work is 6.7.

It would be enlightening is someone could explain why 6.4 works with SE 2007 but 6.7 doesn't. 

Thanks,
Kevin

glimt

  • Community Member
  • Posts: 15
  • Hero Points: 0
Re: GDB Problems
« Reply #2 on: March 07, 2008, 10:57:23 pm »
odd.  I just had the exact opposite problem.

CentOS 4 (Redhat Enterprise) w/ gdb 6.4 wouldn't work.  SlickEdit suggested I download gdb 6.7 and it *kinda* works (attaching causes seg faults).

The problem I had with the built-in slickedit gdb was that it wanted a a newer glibc than I had installed.