Author Topic: How do I turn off auto-bookmarking when class browsing?  (Read 4733 times)

skywise

  • Senior Community Member
  • Posts: 332
  • Hero Points: 9
How do I turn off auto-bookmarking when class browsing?
« on: August 21, 2006, 10:38:28 pm »
So it seems that double clicking on a class/member in the class browser results in a bookmark being dropped at the current location and then the window is opened for the new class/member being desired.  (So that you can just do CTRL-, to jump back to the previous point.

While a nice idea, I usually click on another class to EDIT the other class.  The result is that I end up with a ton of these bookmarks all over the place.  Until today, I thought I was inadvertently hitting some keystroke to cause them to appear...

So...  Is there anyway to turn this feature off?  I've searched through general options, file extension options and tagging options and I don't see this option listed.  (I'm experiencing this in a C++ project, Slickedit 11.01)

Graeme

  • Senior Community Member
  • Posts: 2117
  • Hero Points: 257
Re: How do I turn off auto-bookmarking when class browsing?
« Reply #1 on: August 22, 2006, 12:08:22 am »
So it seems that double clicking on a class/member in the class browser results in a bookmark being dropped at the current location and then the window is opened for the new class/member being desired.  (So that you can just do CTRL-, to jump back to the previous point.

While a nice idea, I usually click on another class to EDIT the other class.  The result is that I end up with a ton of these bookmarks all over the place.  Until today, I thought I was inadvertently hitting some keystroke to cause them to appear...

So...  Is there anyway to turn this feature off?  I've searched through general options, file extension options and tagging options and I don't see this option listed.  (I'm experiencing this in a C++ project, Slickedit 11.01)

You can use the pop-all-bookmarks function to clear them all - bind it to a key (you'll see it listed in the key bindings dialog) or toolbar button if you want.

You might be able to modify the code in cbrowser.e (and other places) where push_destination and push_bookmark are called so that they are either not called at all or only when a variable is set.  I don't know what push_destination does or whether this would work so you might have to dig through the code a bit to try and find out.

Graeme


skywise

  • Senior Community Member
  • Posts: 332
  • Hero Points: 9
Re: How do I turn off auto-bookmarking when class browsing?
« Reply #2 on: August 22, 2006, 04:01:33 am »
Odd... I checked through the vslick\udbackup directories at some of the older cbrowser.e macro files and it looks like this behavior has been around for awhile.  But I've been using VSlick since 6.0 and have never seen this behavior until ver 11...  I wonder if this is the result of a fixed bug or if the bookmark gutter is now turned on...?

skywise

  • Senior Community Member
  • Posts: 332
  • Hero Points: 9
Re: How do I turn off auto-bookmarking when class browsing?
« Reply #3 on: August 22, 2006, 05:40:47 am »
Got it

From VSlick 10's slick.sh (a statement I notice is conspicuously missing from 11)

Quote
/*
   This flag is used by the push_bookmark command.  PUSHED bookmarks
   are mainly useful for tagging where the bookmarks are very temporary.
   By convention, PUSHED bookmarks do not appear on the left edge
   or in the bookmarks dialog and are ignored by all commands excepted
   the pop_bookmark command.
  Don't specify the VSBMFLAG_SHOWNAME or
   VSBMFLAG_STANDARD flags when using this flag.

   In case you were wondering, tag boookmarks are named to simplify
   save and restoring bookmarks.
*/
#define VSBMFLAG_PUSHED       0x4

This behavior has changed and ALL bookmarks are now displayed on the left edge.

A little more digging shows that this bookmark display behavior is now keyed to the following variable in pushtag.e

Quote
boolean def_show_bm_tags=true;

I was about to edit the file to set this to false when I decided to see how else it was used (It's forcibly set to false for Eclipse users because it's not the behavior they expect...>ahem<  ::) ) and discovered that it can be updated through some sort of configuration file.

A quick search back on this forum and this community forum proves its worth.  Somebody's already pointed out that it's possible to set macro variables using Macro | Set Macro Variable and after typing in a few characters of 'def_sh', voila... there's def_show_bm_tags.

Set it to 0 and bang... no more bookmark droppings!  :D :D :D

(Now if I can just figure out where the #include completion behavior is macro-ized so I can do auto-complete like Visual Assist and handle directory changes... :D )

dunkers

  • Senior Community Member
  • Posts: 594
  • Hero Points: 27
Re: How do I turn off auto-bookmarking when class browsing?
« Reply #4 on: August 22, 2006, 04:43:00 pm »
Quote
Until today, I thought I was inadvertently hitting some keystroke
Oh yes! Had me puzzled too... first it was the slightlyly larger left margin that kepy opening up and then I realised it was all these bookmarks.

Instead of changing config #defines, in Tools | Options | Search there is a tickbox: "Show pushed bookmarks". Untick that and you don't get 'em any more, but it doesn't affect normal bookmarks.

skywise

  • Senior Community Member
  • Posts: 332
  • Hero Points: 9
Re: How do I turn off auto-bookmarking when class browsing?
« Reply #5 on: August 22, 2006, 05:42:36 pm »
Even better... thank you.  (I thought there would be an option setting for it... but I would've never thought to look under "search" for it.. )  Thanks!