Author Topic: Open PDF Files From SlickEdit  (Read 9269 times)

Lisa

  • Senior Community Member
  • Posts: 238
  • Hero Points: 23
  • User-friendly geek-speak translator extraordinaire
Open PDF Files From SlickEdit
« on: March 13, 2008, 01:38:53 pm »
You can configure SlickEdit so that it will open a PDF file using your default PDF viewer. To do this, from the main menu, click Tools > Options > File Extension Setup. Click the New button, and enter "pdf" for the extension (leave Refer to blank). Click OK. Next, click the General tab, and select the option Use file association.

Now SlickEdit will use the application that the operating system associates with that extension to open all files of that type that are displayed in the Projects tool window.

TheHumbleOne

  • Community Member
  • Posts: 34
  • Hero Points: 1
Re: Open PDF Files From SlickEdit
« Reply #1 on: November 29, 2010, 06:00:02 pm »
I tried to configure SlickEdit to open PDF files with Adobe Acrobat, but SlickEdit continues to load them from within SlickEdit.  I am using SlickEdit version 15.0.1.3 and I don't see the configuration option that this forum post talks about.  When I double-click on a PDF file from within the SlickEdit file manager, I want Adobe Acrobat to open that file.

Graeme

  • Senior Community Member
  • Posts: 1921
  • Hero Points: 220
Re: Open PDF Files From SlickEdit
« Reply #2 on: December 14, 2010, 10:25:18 am »
It's now tools -> options -> languages -> file extension manager.  Click new, enter pdf for the extension, click ok.  Click the "use file association" checkbox so that it is "checked".

TheHumbleOne

  • Community Member
  • Posts: 34
  • Hero Points: 1
Re: Open PDF Files From SlickEdit
« Reply #3 on: December 14, 2010, 04:14:25 pm »
This is what I am doing:

Options --> Languages --> File Extension Manager --> Click on "New" button, type "pdf" in the Extension field, Select "Plain Text" in the Language field.

On the main window that opened, kept "Automatic" as Encoding; selected the "Use file association" checkbox and clicked on "Apply".  Restarted the application and double-clicked on a PDF file from within SlickEdit file manager.  This should have launched Adobe Acrobat since it's associated with the file of type PDF, but it did not work.  The file was opened within SlickEdit -- as if it's a plain text file.

I also tried another thing.  Within the File Extension Manager window, I unchecked the "Use file association" checkbox and instead typed "c:\Program Files\Adobe\Reader 9.0\Reader\AcroRd32.exe" "%1" in the "Open application with" field.  This did not work either, as the PDF file was again opened within the SlickEdit editor.

Is there a step that I am missing?  I am using version 15.0.1.3 on Windows XP.  My PDF file association works from within Windows Explorer -- so file association is not the problem.

Sandra

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 754
  • Hero Points: 35
Re: Open PDF Files From SlickEdit
« Reply #4 on: December 14, 2010, 04:49:04 pm »
I think this is a bug.  I'll file a defect for it and look into fixing it.

Thanks!

Sandra

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 754
  • Hero Points: 35
Re: Open PDF Files From SlickEdit
« Reply #5 on: December 14, 2010, 05:00:10 pm »
After I reread Lisa's original post, I saw the problem.  The file association only works when you open the file from within the Projects tool window.  So when you open the file from the Open tool window (or from the command line), then SlickEdit just opens the file within itself.  I think this is as designed, thought it's not terribly obvious from the GUI, though it is specified in the documentation for the File Extension Manager options page.

TheHumbleOne

  • Community Member
  • Posts: 34
  • Hero Points: 1
Re: Open PDF Files From SlickEdit
« Reply #6 on: December 14, 2010, 05:07:43 pm »
Sandra:

Thank you for your explanation.  Now I see your point.  I am able to open a PDF file from within the Projects window using Adobe Acrobat.  This solves my problem.

Thanks!