Author Topic: Invalid xmlcfg handle  (Read 8604 times)

perssontm

  • Community Member
  • Posts: 13
  • Hero Points: 0
Invalid xmlcfg handle
« on: March 14, 2008, 09:56:13 pm »
Trying to use this tool I ran into another problem, I used the "Add tree" function to add a variety of source files from a project, totalling 7200 files. The add went well, but clicking Ok in the project properties gave me after some while of tagging "Invalid xmlcfg handle" and the following stacktrace.

/Eric
-----

 cat /tmp/vsstack.eric
 Slick-C STACK TRACE ******************************
 Created on 3/14/2008 at 22:52:19 (856 ms)
 SlickEdit Version 12.0.3.0 Copyright 1988-2007 SlickEdit Inc.
 Edit module and type "st -f <offset>" to get the
 run-time error position

 error code=-5433
 Invalid XMLCFG handle

 0x878e1b0 -xmlcfg-delete(10,0,1)   p_window_id: 216   p_object: OI_COMMAND_BUTTON   p_name: _ok
project.ex 34305 static()   p_window_id: 216   p_object: OI_COMMAND_BUTTON   p_name: _ok
project.ex 33974 _project_form._ok.\x{157d}()   p_window_id: 97   p_object: OI_FORM   p_name:
dlgeditv.ex 7415 show(-mdi -modal -xy _project_form,
   2:   /home/eric/dev/easyinteraction.net/trunk/EasyStaticTrunk.vpj
   3:   10
   4:   0
   p_window_id: 97
   p_object: OI_FORM
   p_name:
project.ex 281 static(0,/home/eric/dev/easyinteraction.net/trunk/EasyStaticTrunk.vpj)
   p_window_id: 139
   p_object: OI_SSTAB_CONTAINER
   p_name:
project.ex 434 project_edit(0)   p_window_id: 139   p_object: OI_SSTAB_CONTAINER   p_name:
projutil.ex 2324 show_project_properties_files_tab(Release)   p_window_id: 139   p_object: OI_SSTAB_CONTAINER   p_name:
project.ex 2429 workspace_new_project2(/home/eric/dev/easyinteraction.net/trunk/EasyStaticTrunk.vpj,
   2:   PHP
   3:   EasyStaticTrunk
   4:   /home/eric/dev/easyinteraction.net/trunk/EasyStaticTrunk.vpw
   5:   0
   6:   1
   7:   
   8:   
   9:   0
   10:   <empty>
   11:   0
   12:   1
   p_window_id: 139
   p_object: OI_SSTAB_CONTAINER
   p_name:
wkspace.ex 30568 workspace_new_project(1,PHP,EasyStaticTrunk,
   4:   /home/eric/dev/easyinteraction.net/trunk/
   5:   0
   6:   EasyStaticTrunk
   7:   
   p_window_id: 139
   p_object: OI_SSTAB_CONTAINER
   p_name:
wkspace.ex 32095 _workspace_new_form.ctlok.\x{24a8}()   p_window_id: 153   p_object: OI_FORM   p_name: _project_form
dlgeditv.ex 7415 show(-modal _workspace_new_form,P)   p_window_id: 97   p_object: OI_FORM   p_name:
wkspace.ex 29694 workspace_new(1,<empty>,<empty>)   p_window_id: 97   p_object: OI_FORM   p_name:

kedar

  • New Community Member
  • Posts: 1
  • Hero Points: 0
Re: Invalid xmlcfg handle
« Reply #1 on: December 17, 2008, 07:40:44 pm »
This seems to be a very old post. Did you find a solution to the problem? I am observing the same issue.

buggyfunbunny

  • Senior Community Member
  • Posts: 234
  • Hero Points: 4
Re: Invalid xmlcfg handle
« Reply #2 on: March 12, 2009, 01:13:51 am »
I get this in 13.0.2/ubuntu/64 when creating a python project.  Just started with *nix version of SE, and it's been a while since I've done any Python, so I've no idea whether this is some sort of User Error. 

For Yucks, I made a New Project, and ran the Auto Folder button, and added the additional extensions, and it ran OK.  Likely not a coincidence, but I've no idea why.

ScottW, VP of Dev

  • Senior Community Member
  • Posts: 1471
  • Hero Points: 64
Re: Invalid xmlcfg handle
« Reply #3 on: March 13, 2009, 03:12:16 pm »
If you search for "Invalid xmlcfg" you will find that a number of issues have been reported with this as the error message. All of these error relate to a problem in process an XML file. Though the error message is very similar, the problems that cause them are often very distinct.

If you get this problem using our UI to create a project and add files to it, please report the issue to Product Support. We want to fix these issues, and your bug reports are the key to identifying where they are occuring.

This should only be a case of "user error" if you are manually creating or modifying the project or workspace files.

john.dehelian

  • Community Member
  • Posts: 10
  • Hero Points: 1
Re: Invalid xmlcfg handle
« Reply #4 on: January 16, 2012, 02:02:14 pm »
I got this when I switched from having the file tabs sorted alphabetically to manual. My whole UBuntu system locked up and I powered down. When I came back up I had this problem. Here is the trace:

 Invalid XMLCFG handle
 0x88163e0 -xmlcfg-find-simple-array(-5402,/History/Option/@DateChanged[contains(.,'^:d:16$', 'R')],<empty>)   p_window_id: 204   p_object: OI_TREE_VIEW   p_name: _ctl_tree
OptionsConfigurationXMLParser.ex 3249 se.options.OptionsConfigurationXMLParser.checkForOldTimeStyle(
   1:   ._typename()=se.options.OptionsConfigurationXMLParser
   1:   .m-xmlConfigHandle=-5402
   1:   .m-xmlConfigFile=optionsConfig.xml
   p_window_id: 204
   p_object: OI_TREE_VIEW
   p_name: _ctl_tree
OptionsConfigurationXMLParser.ex 139 se.options.OptionsConfigurationXMLParser.init(
   1:   ._typename()=se.options.OptionsConfigurationXMLParser
   1:   .m-xmlConfigHandle=-5402
   1:   .m-xmlConfigFile=optionsConfig.xml
   p_window_id: 204
   p_object: OI_TREE_VIEW
   p_name: _ctl_tree
OptionsXMLParser.ex 571 se.options.OptionsXMLParser.initParser(
   1:   ._typename()=se.options.OptionsXMLParser
   1:   .m-xmlHandle=5
   1:   .m-xmlFile=options.xml
   1:   .m-defaultFile=0
   1:   .m-templates=<empty>
   1:   .m-propTemplates=(null)
   1:   .m-included=<empty>
   1:   .m-shownNodes=<empty>
   1:   .m-favorites=<empty>
   1:   .m-protections=(null)
   1:   .m-configParser._typename()=se.options.OptionsConfigurationXMLParser
   1:   .m-configParser.m-xmlConfigHandle=-5402
   1:   .m-configParser.m-xmlConfigFile=optionsConfig.xml
   1:   .m-xmlExportHandle=0
   1:   .m-xmlExportFile=optionsExportGroups.xml
   1:   .m-topNode=10
   1:   .m-languageBegin=-1
   1:   .m-dialogTemplates=-1
   1:   .m-propertyTemplates=-1
   1:   .m-versionControlBegin=-1
   1:   .m-optionsTreePurpose=0
   2:   0
   3:   /home/john/slickedit/sysconfig/options/quickStartConfig.xml
   p_window_id: 204
   p_object: OI_TREE_VIEW
   p_name: _ctl_tree
OptionsTree.ex 2292 se.options.OptionsTree.init(
   1:   ._typename()=se.options.OptionsConfigTree
   1:   .m-treeHandle=204
   1:   .m-frameHandle=206
   1:   .m-helpHandle=222
   1:   .m-currentPanelWid=0
   1:   .m-currentCaption=
   1:   .m-currentTreeIndex=0
   1:   .m-relations._typename()=se.options.RelationTable
   1:   .m-relations.m-table=<empty>
   1:   .m-parser._typename()=se.options.OptionsXMLParser
   1:   .m-parser.m-xmlHandle=5
   1:   .m-parser.m-xmlFile=options.xml
   1:   .m-parser.m-defaultFile=0
   1:   .m-parser.m-templates=<empty>
   1:   .m-parser.m-propTemplates=(null)
   1:   .m-parser.m-included=<empty>
   1:   .m-parser.m-shownNodes=<empty>
   1:   .m-parser.m-favorites=<empty>
   1:   .m-parser.m-protections=(null)
   1:   .m-parser.m-configParser._typename()=se.options.OptionsConfigurationXMLParser
   1:   .m-parser.m-configParser.m-xmlConfigHandle=-5402
   1:   .m-parser.m-configParser.m-xmlConfigFile=optionsConfig.xml
   1:   .m-parser.m-xmlExportHandle=0
   1:   .m-parser.m-xmlExportFile=optionsExportGroups.xml
   1:   .m-parser.m-topNode=10
   1:   .m-parser.m-languageBegin=-1
   1:   .m-parser.m-dialogTemplates=-1
   1:   .m-parser.m-propertyTemplates=-1
   1:   .m-parser.m-versionControlBegin=-1
   1:   .m-parser.m-optionsTreePurpose=0
   1:   .m-data._typename()=se.options.OptionsData
   1:   .m-data.m-panelWIDs=<empty>
   1:   .m-data.m-panelInfo=<empty>
   1:   .m-data.m-sharedWIDs=<empty>
   1:   .m-navigator._typename()=se.options.OptionsHistoryNavigator
   1:   .m-navigator.m-history=<empty>
   1:   .m-navigator.m-current=-1
   1:   .m-navigator.m-top=-1
   1:   .m-dialogArg=
   1:   .m-optionsChangeDelay=1
   1:   .m-dialogsAsSummaries=1
   1:   .m-optionsTreePurpose=0
   1:   .m-modified=<empty>
   1:   .m-searching=0
   1:   .m-searchTerm=
   1:   .m-searchOptions=
   1:   .m-renamedLanguages=<empty>
   1:   .m-doProcessPanels=1
   2:   204
   3:   206
   4:   222
   5:   /home/john/slickedit/sysconfig/options/quickStartConfig.xml
   p_window_id: 204
   p_object: OI_TREE_VIEW
   p_name: _ctl_tree
OptionsConfigTree.ex 2319 se.options.OptionsConfigTree.init(
   1:   ._typename()=se.options.OptionsConfigTree
   1:   .m-treeHandle=204
   1:   .m-frameHandle=206
   1:   .m-helpHandle=222
   1:   .m-currentPanelWid=0
   1:   .m-currentCaption=
   1:   .m-currentTreeIndex=0
   1:   .m-relations._typename()=se.options.RelationTable
   1:   .m-relations.m-table=<empty>
   1:   .m-parser._typename()=se.options.OptionsXMLParser
   1:   .m-parser.m-xmlHandle=5
   1:   .m-parser.m-xmlFile=options.xml
   1:   .m-parser.m-defaultFile=0
   1:   .m-parser.m-templates=<empty>
   1:   .m-parser.m-propTemplates=(null)
   1:   .m-parser.m-included=<empty>
   1:   .m-parser.m-shownNodes=<empty>
   1:   .m-parser.m-favorites=<empty>
   1:   .m-parser.m-protections=(null)
   1:   .m-parser.m-configParser._typename()=se.options.OptionsConfigurationXMLParser
   1:   .m-parser.m-configParser.m-xmlConfigHandle=-5402
   1:   .m-parser.m-configParser.m-xmlConfigFile=optionsConfig.xml
   1:   .m-parser.m-xmlExportHandle=0
   1:   .m-parser.m-xmlExportFile=optionsExportGroups.xml
   1:   .m-parser.m-topNode=10
   1:   .m-parser.m-languageBegin=-1
   1:   .m-parser.m-dialogTemplates=-1
   1:   .m-parser.m-propertyTemplates=-1
   1:   .m-parser.m-versionControlBegin=-1
   1:   .m-parser.m-optionsTreePurpose=0
   1:   .m-data._typename()=se.options.OptionsData
   1:   .m-data.m-panelWIDs=<empty>
   1:   .m-data.m-panelInfo=<empty>
   1:   .m-data.m-sharedWIDs=<empty>
   1:   .m-navigator._typename()=se.options.OptionsHistoryNavigator
   1:   .m-navigator.m-history=<empty>
   1:   .m-navigator.m-current=-1
   1:   .m-navigator.m-top=-1
   1:   .m-dialogArg=
   1:   .m-optionsChangeDelay=1
   1:   .m-dialogsAsSummaries=1
   1:   .m-optionsTreePurpose=0
   1:   .m-modified=<empty>
   1:   .m-searching=0
   1:   .m-searchTerm=
   1:   .m-searchOptions=
   1:   .m-renamedLanguages=<empty>
   1:   .m-doProcessPanels=1
   2:   204
   3:   206
   4:   222
   5:   /home/john/slickedit/sysconfig/options/quickStartConfig.xml
   p_window_id: 204
   p_object: OI_TREE_VIEW
   p_name: _ctl_tree
optionsxml.ex 18314 _options_tree_form._ctl_tree.\x{1107}(3,,1,0,)   p_window_id: 204   p_object: OI_TREE_VIEW   p_name: _ctl_tree
dlgeditv.ex 6721 show(-modal -mdi _options_tree_form,3)   p_window_id: 215   p_object: OI_EDITOR   p_name:
quickstart.ex 93 quick_start()   p_window_id: 215   p_object: OI_EDITOR   p_name:

Sandra

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 754
  • Hero Points: 35
Re: Invalid xmlcfg handle
« Reply #5 on: January 16, 2012, 02:15:31 pm »
If you look in your configuration directory, there should be a file named "optionsConfig.xml."  Try renaming that file and see if that helps. 

Also, if you could post that optionsConfig.xml file here so I could take a look at it, that would be great.

john.dehelian

  • Community Member
  • Posts: 10
  • Hero Points: 1
Re: Invalid xmlcfg handle
« Reply #6 on: January 18, 2012, 11:49:06 am »
 :) Yes that worked. I looked for it but hadn't realized it was in the hidden folder .slickedit. I had also tried just renaming that folder and a new one was created that worked also though I had lost all my other settings. Thank you. Attached is the bad file.

slickMS

  • Community Member
  • Posts: 9
  • Hero Points: 0
Re: Invalid xmlcfg handle
« Reply #7 on: February 28, 2012, 05:20:32 pm »
I tried renaming 'optionsConfig.xml', then restarting Visual Slick Edit, but it made NO difference. I also get the "Invalid xmlcfg handle" error message when doing ~any~ subversion action.

I am running SlickEdit 2011 (v16.0.3.0 64-bit) and I have the following hotfixes installed:
/home/mark/.slickedit/16.0.3/hotfixes/hotfix_se1603_9_cumulative.zip (Revision: 9)
/home/mark/.slickedit/16.0.3/hotfixes/hotfix_se1603_5_cumulative.zip (Revision: 5)

OS Information:
OS: Linux
OS Version: Ubuntu 11.10
Kernel Level: 3.0.0-16-generic
Build Version: #28-Ubuntu SMP Fri Jan 27 17:44:39 UTC 2012
Processor Architecture: x86_64


Any help would be appreciated.
Thanks

Sandra

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 754
  • Hero Points: 35
Re: Invalid xmlcfg handle
« Reply #8 on: February 28, 2012, 05:22:05 pm »
Could you post your vs.log file?  You'll find it in your configuration directory, under the "logs" subdirectory.

slickMS

  • Community Member
  • Posts: 9
  • Hero Points: 0
Re: Invalid xmlcfg handle
« Reply #9 on: February 28, 2012, 05:58:44 pm »
Sure!. Here it is!

Thanks again!

Dan

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 2074
  • Hero Points: 101
Re: Invalid xmlcfg handle
« Reply #10 on: February 28, 2012, 07:52:40 pm »
It looks like we have tried to get some output from Subversion in XML, and that output is not valid.

Can you run SlickEdit from a console window, and set the macro variable _CVSDebug to 1?  Then perform an SVN operation that will result in an error, and some debug will be output into that console - please send it to me.  You can use PM, or PM me for an email address.

slickMS

  • Community Member
  • Posts: 9
  • Hero Points: 0
Re: Invalid xmlcfg handle
« Reply #11 on: February 28, 2012, 08:24:35 pm »
Thank you, Dan!

Turning on the debugging info showed me that Subversion was returning errors itself, such as:
"xyz: no version information available"
The the ~real~ output would follow.

I will debug this from here, thanks.

Dan

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 2074
  • Hero Points: 101
Re: Invalid xmlcfg handle
« Reply #12 on: February 28, 2012, 08:25:19 pm »
...and I will put in a check for a failure opening because of invalid XML ;)

slickMS

  • Community Member
  • Posts: 9
  • Hero Points: 0
Re: Invalid xmlcfg handle
« Reply #13 on: August 06, 2012, 03:46:24 pm »
Has there been any bug fix for this. I am unable to do ~ANY~ subversion action
from within SlickEdit. I am running the following:

SlickEdit 2011 (v16.0.3.0 64-bit) with hotfix_se1603_12_cumulative.zip
installed as well.

OS: Linux
OS Version: Ubuntu 11.10
Kernel Level: 3.0.0-23-generic
Build Version: #39-Ubuntu SMP Thu Jul 19 19:19:11 UTC 2012
Processor Architecture: x86_64

I would appreciate any help on this.

Dan

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 2074
  • Hero Points: 101
Re: Invalid xmlcfg handle
« Reply #14 on: August 08, 2012, 02:02:34 pm »
Your last post indicated you were getting errors from Subversion and we weren't catching them, have those been resolved?

If you'd like, PM me an email address, we may be able to resolve this faster that way.