Author Topic: setting breakpoint disabled  (Read 2036 times)

sachinkundu

  • New Community Member
  • Posts: 1
  • Hero Points: 0
setting breakpoint disabled
« on: March 30, 2008, 01:53:43 am »
Hi

I have a Linux custom makefile project. I have added the source files and headers to a slickedit project. Also the makefile is added. I can fire make from within the slickedit UI after setting the commands in the Tools tab of project properties dialog box.

However my debug menu is almost empty. There is a start debugging option which doesnt do anything by itself. If i add in tools tab under project properties,path to gdb then gdb is launched and i can do whatever i do with a gdb terminal.

Why is my menu for debugging greyed out ? How can i set up the project which will help me set visual breakpoints ?

I have updated to the gdb 6.7.1 version as mentioned in the online help manual and set the path in debugger options and made it default.

Thanks
Sachin Kundu

hs2

  • Senior Community Member
  • Posts: 2727
  • Hero Points: 281
Re: setting breakpoint disabled
« Reply #1 on: March 30, 2008, 09:54:18 am »
I think you need to use the GNU C/C++ project type to get gdb debugging enabled, but I'm not sure.
Did also you try to 'Debug>..>Attach to a running process' ?
HS2

ScottW, VP of Dev

  • Senior Community Member
  • Posts: 1471
  • Hero Points: 64
Re: setting breakpoint disabled
« Reply #2 on: March 31, 2008, 02:32:26 pm »
When you created the project, what project type did you select? If you want to work with GNU, it is important to select the GNU C/C++ Wizard.