Author Topic: Enter key changed behavior  (Read 5418 times)

PaulSW

  • Community Member
  • Posts: 5
  • Hero Points: 0
Enter key changed behavior
« on: August 24, 2006, 11:53:09 pm »
My enter key behaves differently than it used to and how I like.  Using ISPF emulation, I would like the enter key to execute the line commands.  It now gives me a new line and does not execute the line commands.

I can get the right-ctrl key or ctrl-enter to execute the line commands, but I cannot get the enter key to work that way.

Help!

Dennis

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 2649
  • Hero Points: 409
Re: Enter key changed behavior
« Reply #1 on: August 28, 2006, 02:41:53 pm »
First question, what language mode are you in?  Cobol, C, Ada, Assembler, PL/I?  Do you have this problem in all modes or just particular ones?

To verify that Enter is bound to the the correct command, Go to "Help" > "What is Key" and press Enter.  It should be ispf-enter, c_enter, cobol-enter or some other language specific "enter" key.

PaulSW

  • Community Member
  • Posts: 5
  • Hero Points: 0
Re: Enter key changed behavior
« Reply #2 on: August 28, 2006, 03:22:12 pm »
Thanks for the reply.  This is getting more mysterious.


Here are the answers to your questions:

1. I am using slickedit in C++ mode.
2. When I click on Help and hit enter I get <nothing>.  If I click the mouse, I get a list of associations.
3. After I shut my system down (I normally don't do that very often), it came back behaving as I wanted.  It apparently "fixed" itself, which is not necessarily a good thing.  I am very suspicious of things that fix themselves.
4. When I click on Help-Keys, I get the pop-up, "Help item 'ispf keys; not found.

Thanks again for your help,
Paul

Dennis

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 2649
  • Hero Points: 409
Re: Enter key changed behavior
« Reply #3 on: August 28, 2006, 05:13:54 pm »
If you have SlickEdit 11.0 or newer, there is an item on the Help menu "What is Key...".  If you have an older version of SlickEdit, you will need to click on the command line and enter the command "what-is".  You will be prompted for a key, hit Enter.  It should now show you what the Enter key is bound to.  For C++, that should be c_enter.

If for some reason, Enter is not bound to c_enter, you should go to Tools > Options > Key Bindings..., and bind it back to c_enter() for "C" mode only (uncheck "Affect all modes).

--Dennis

PaulSW

  • Community Member
  • Posts: 5
  • Hero Points: 0
Re: Enter key changed behavior
« Reply #4 on: August 28, 2006, 05:51:04 pm »
The key does not work the way I want and the way it used to work :-(  .

There is indeed an entry under help called "What is key..."  However, it does nothing when I press Enter, Ctrl-Enter, or Ctrl.  It does respond with  a list on a mouse click.

I went to Tools-Options-Key Bindings.  When I click on c-enter, it says that Enter is bound to Enter if I have unchecked "Affect all modes."  If I check "Affect all modes," it says that c-enter is not bound to a key.

The bad symptoms are that Enter only moves the cursor to the beginning of the next line.  To execute line commands I must either press ctrl-enter or right-ctrl.

Dennis

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 2649
  • Hero Points: 409
Re: Enter key changed behavior
« Reply #5 on: August 28, 2006, 06:19:59 pm »
First a terminology question:  I realize that some ISPF users tend to start thinking of right control as Enter, so I have to ask.  When I talk about the "Enter" key, I am talking about the key with the word "Enter" on it on your main keyboard.  Are we in agreement here?

Second, a possible solution for you:  Go to Tools > Options > ISPF Options...  Is "Right Ctrl = Enter/Send" on or off?  If you have it on, then Enter will not do line commands (because you would presumably use right control instead).

Hope this helps.

--Dennis

PaulSW

  • Community Member
  • Posts: 5
  • Hero Points: 0
Re: Enter key changed behavior
« Reply #6 on: August 28, 2006, 07:32:34 pm »
That seems to have gotten it!

I had checked right-ctrl when the enter key stopped working correctly (it would insert a new line and not execute line commands).  Rebooting my system mysteriously solved the enter key problem of creating a new line.  Now by unchecking the ctrl-enter box under options everything is good once again.

Thanks again.

PaulSW

  • Community Member
  • Posts: 5
  • Hero Points: 0
Re: Enter key changed behavior
« Reply #7 on: August 28, 2006, 09:38:51 pm »
It is broken again.  This is why I distrust things that fix themselves; they can also break themselves.

It worked correctly for a while (a few hours before lunch), but now it is misbehaving again.  I have not touched the settings.

I suspect that it is some kind of key combination that toggles the editor into a different mode, but I am unable to find it.

The symptom is that the enter key inserts a new line and puts the cursor on the new line.  Any line commands are neatly ignored.  Since I have turned off the right-ctrl option, the only way to execute line commands is to hit ctrl-enter :-{  .  I will turn ctrl-enter back on because it is just too annoying the way it is.