Author Topic: Loaded SE2008 and get no perl tagging  (Read 3997 times)

ghauck

  • Guest
Loaded SE2008 and get no perl tagging
« on: March 31, 2008, 05:45:13 pm »
I downloaded the latest SE2008 and it works great for everything but perl. DEFS and language help are working, it is all just black and white though. All the setting for perl look exactly like they are for SE2007. Any thoughts?

Guy.

Matthew

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 990
  • Hero Points: 44
Re: Loaded SE2008 and get no perl tagging
« Reply #1 on: March 31, 2008, 06:21:09 pm »
Try this: Activate the command line and enter the command fundamental-mode (which sets coloring to the 'plain text' setting), and then activate the command line again and enter perl-mode. Does the coloring show correctly then?

Under the Tools>Options>Languages>File Extension Manager, make sure your .pl, .plx, etc extensions are correctly mapped to Perl in the 'Associate with language' drop-down.

ghauck

  • Guest
Re: Loaded SE2008 and get no perl tagging
« Reply #2 on: March 31, 2008, 07:28:43 pm »
I executed those mode commands and nothing happened. Tried it with a rexx program and fundamental and back to rexx mode worked as you described. ".pl" is defined to Perl and all Perl function help works normally, just no tagging.

Thanks, Guy.

Matthew

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 990
  • Hero Points: 44
Re: Loaded SE2008 and get no perl tagging
« Reply #3 on: March 31, 2008, 08:01:30 pm »
Is this happening with all your perl files, or just one? There may be a syntax construct that we're not reading that is being mis-interpreted, and that might be turning off colorization mid-stream.

First thing to check is that SE really does think this is a perl file. Look on the Document menu, and you should see 2 menu entries in the first group, Select Mode (Perl)... and Perl Options.

If this is an extensionless file, does the file start with the #!/usr/bin/perl, or similar she-bang string?

ghauck

  • Guest
Re: Loaded SE2008 and get no perl tagging
« Reply #4 on: March 31, 2008, 08:55:56 pm »
It is all my perl files. I do have Mode(perl) and perl options in the menu. I also have the #!/usr/bin/perl string. (actually #!/usr/bin/perl -w --)

Guy

Matthew

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 990
  • Hero Points: 44
Re: Loaded SE2008 and get no perl tagging
« Reply #5 on: March 31, 2008, 09:41:29 pm »
Ok, then it sounds like your files and the file extension settings are correct. If you've modified the default perl syntax settings (like added some keywords, etc) there may have been a problem migrating to the new options format.

The next thing to check is the definition of the perl language itself. Go to Tools > Options > Languages > Scripting Languages > Perl > Advanced. In the "Color Coding" options box you should see the label "Lexer name: perl". If that is not set correctly, then click the "Color Coding..." button and make sure that Perl shows up in Lexer name drop-down. Click OK to save the change and restart SlickEdit.

If *that* fails to restore your coloring, find the user.vlx file in your 13.0.0 configuration directory. The definition for the perl language will be in that file if you've made modifications to it. Make a backup copy of that user.vlx file (outside the config directory), then delete the perl section, save user.vlx, and restart SlickEdit.

ghauck

  • Guest
Re: Loaded SE2008 and get no perl tagging
« Reply #6 on: April 01, 2008, 12:01:24 pm »
SCORE!!!! That was it. The lexer was blank.

Thanks!
Guy.