Author Topic: Wrapping html?  (Read 4948 times)

Christoph

  • Senior Community Member
  • Posts: 114
  • Hero Points: 6
Wrapping html?
« on: April 14, 2008, 04:25:51 pm »
Given the code below:

Code: [Select]
<table>
  <tr>
    <td>
      sadf asdf asdf asdf asdf asdf asdf asdf asdf asdf asdf asdf asdf asdf asdf
      asdf
    </td>
  </tr>
</table>

It seems like SE2k8 is automatically wrapping any/everything at 82 characters.  If I try to move the second line of the text to the first line, it autowraps as soon as I type anything.  I've gone into the language settings for HTML and have made sure that the "Word Wrap" checkbox is unchecked in the "Word Wrap" settings node.  Additionally, just to be sure, I've set the right margin to "9999".  I've also gone through all the settings nodes to see if there was anything that had a value of 81 or 82 that might be affecting this but came up with nothing.

So what's going on?  Why is SE2k8 still wrapping my HTML?

thnx,
Christoph

jbhurst

  • Senior Community Member
  • Posts: 405
  • Hero Points: 33
Re: Wrapping html?
« Reply #1 on: April 14, 2008, 05:40:35 pm »
Hi Christoph,

You need to disable "HTML formatting" under Document > XML/HTML Formatting.

I have no idea why this setting is here rather than in the language settings. Enabling or disabling it through the Document menu effects a global change.

Regards

John Hurst
Wellington, New Zealand

chrisant

  • Senior Community Member
  • Posts: 1410
  • Hero Points: 131
Re: Wrapping html?
« Reply #2 on: April 14, 2008, 05:41:27 pm »
This link has info on how to set your HTML settings to wrap how you want.
http://community.slickedit.com/index.php?topic=3143.msg12967#msg12967

The key is that HTML word wrapping is different from the other languages -- the "word wrapping" setting isn't the one you need to modify, instead you need to modify several settings on the "HTML Formatting" node in the Options dialog, and also settings in the Configure Schemes dialog.