Author Topic: SlickEdit Slow to Respond with ClearCase Dynamic Views  (Read 8320 times)

davew

  • Senior Community Member
  • Posts: 224
  • Hero Points: 6
SlickEdit Slow to Respond with ClearCase Dynamic Views
« on: April 24, 2008, 09:21:10 am »
When coming from another application into SlickEdit (Alt-Tab or whatever), SlickEdit appears to freeze for a long time when files in ClearCase dynamic views are open.

I compared with my old CodeWright editor and it is immediate, so I assume SlickEdit is doing some extra processing.

Has anyone else experienced this or does anyone know of any settings or tweaks to reduce this?

skilleter

  • Community Member
  • Posts: 14
  • Hero Points: 0
Re: SlickEdit Slow to Respond with ClearCase Dynamic Views
« Reply #1 on: April 28, 2008, 11:32:45 am »
I see this quite often with Slickedit v12 and ClearCase under Linux and, as you say, other applications don't do it.

davew

  • Senior Community Member
  • Posts: 224
  • Hero Points: 6
Re: SlickEdit Slow to Respond with ClearCase Dynamic Views
« Reply #2 on: May 05, 2008, 11:59:42 am »
One of the things that I have noticed is that if the view goes away, SlickEdit will lockup. There needs to be a timeout on whatever it is doing.

And as far as the slow update, it would be nice if the SlickEdit team identified what functions are being used which are causing the slow update for situations where the network link may be temporarily slow (such as with ClearCase Dynamic Views). Then we could disable those functions (assuming they are options) if we don't want to wait.

I believe there should also be a configurable timeout for file access functions. If the file is taking too long to respond, the user could be presented with an option to continue to wait or use the file as-is (maybe with a consequence warning).

doobiedoo@alum.mit.edu

  • New Community Member
  • Posts: 1
  • Hero Points: 0
Re: SlickEdit Slow to Respond with ClearCase Dynamic Views
« Reply #3 on: August 05, 2009, 04:46:41 am »
I had the same problem. 
Slickedit is much better after setting macro variable def_vc_advanced_options to 0 (default is 3)
using menu Macro, Set Macro variable…, def_vc_advanced_options, change the value to 0, click on OK.

Not sure what ClearCase options get disabled, but I haven't noticed any missing functionality in 1 week.
--ddoo  Aug 04, 2009

skilleter

  • Community Member
  • Posts: 14
  • Hero Points: 0
Re: SlickEdit Slow to Respond with ClearCase Dynamic Views
« Reply #4 on: August 05, 2009, 08:21:30 am »
Interesting, thanks, I shall have to investigate this, although I've pretty much given up on Slickedit these days.