Author Topic: Eclipse Core Bugs, etc.  (Read 5441 times)

bercikr

  • Community Member
  • Posts: 45
  • Hero Points: 2
Eclipse Core Bugs, etc.
« on: April 28, 2008, 05:54:29 pm »
Ryan,

    I was wondering where we should submit bug reports for slickedit Core functionality that does not seem to be working properly? As of now I cannot seem to get the gui-write-selection command to work properly. When I try to use it i get the following error message:

Quote
---------------------------
SlickEdit Core
---------------------------
Unable to write selection to +futf8  C:\userhome\intuit\tpsworkspace\test.t. Text not selected
---------------------------
OK   
---------------------------

I also tried this out in SlickEdit 2008 to make sure I was using it properly.

Thanks,
Rob
Rob

Ryan

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 987
  • Hero Points: 77
Re: Eclipse Core Bugs, etc.
« Reply #1 on: April 28, 2008, 06:28:48 pm »
Submit bug reports to support@slickedit.com...they will always be reviewed and responded to, and fowarded to a developer if necessary.

Be aware that not all slickedit commands on the command line work in the plug-in as they do in the standalone product.  Though lots of commands do work, we make no guarantees (see the help on SlickEdit Core Command Line) that they will all work, or that they are all supported.  The environments are different, and some commands we actually disable.   

That being said, I will probably always try to fix any command that isn't working for you...in this case it looks like there is a problem with the put command in Core.  When I get a chance to debug it I will let you know what the deal is.

- Ryan

Ryan

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 987
  • Hero Points: 77
Re: Eclipse Core Bugs, etc.
« Reply #2 on: April 28, 2008, 06:30:57 pm »
Oh and if you have a list of commands you are trying to use which apparently aren't supported or aren't functioning right in Core, definitely send that in to support.  Customer requests help us prioritize fixes.  Thanks.

- Ryan

Ryan

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 987
  • Hero Points: 77
Re: Eclipse Core Bugs, etc.
« Reply #3 on: April 28, 2008, 08:54:12 pm »
I was wrong :), but the attached version of guiopen.e should fix the problem.  Backup your copy of guiopen.e and save the attached version to your macros directory.  Load via Macro > Load Module or by opening the file in Eclipse and hitting F12. 

- Ryan