Author Topic: SourceSafe not working with SlickEdit 2008  (Read 4398 times)

jorick

  • Senior Community Member
  • Posts: 320
  • Hero Points: 15
SourceSafe not working with SlickEdit 2008
« on: May 20, 2008, 02:08:43 pm »
I have a project I'm working with that uses SourceSafe for version control.  When I check out a file in SlickEdit, the file stays read-only and it never gets checked out.  How do I get SlickEdit to check out a file?

Dan

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 1852
  • Hero Points: 75
Re: SourceSafe not working with SlickEdit 2008
« Reply #1 on: May 21, 2008, 02:25:12 pm »
I have a few questions that might shed some light on the subject:

  • Are you using the SCC interface?
  • Did you open an appropriate SCC project?
  • How are you trying to check the file out?
  • Did this work in any previous version?

jorick

  • Senior Community Member
  • Posts: 320
  • Hero Points: 15
Re: SourceSafe not working with SlickEdit 2008
« Reply #2 on: June 06, 2008, 12:18:35 pm »
I'm set up to use SCC providers and Microsoft Visual SourceSafe is selected.

The project is set to "$/New Platform", AICAAAA which appears to be correct.

I've tried to check it out a number of different ways.  One way is when I type in a read-only file and it pops up the dialog box asking if I want to check it out.  Another way is to click on the check out icon on the tool bar.  Neither way works.

I don't know if it worked in any other version because I've just started trying to use it.

=====

SlickEdit Version 13.0.0.0

Build Date: March 26, 2008
Emulation: CodeWright

OS: Windows XP
Version: 5.01.2600  Service Pack 3

Installation Directory: C:\Program Files\SlickEdit 2008\ (non-removable drive,NTFS)
Configuration Directory: C:\Documents and Settings\rbennet\My Documents\My SlickEdit Config\13.0.0\ (non-removable drive,NTFS)

Hotfixes:
C:\Documents and Settings\rbennet\My Documents\My SlickEdit Config\13.0.0\hotfixes\hotfix_se1300_cumulative.zip (Revision: 22)
C:\Documents and Settings\rbennet\My Documents\My SlickEdit Config\13.0.0\hotfixes\hotfix_se1300_required.zip (Revision: 2)



Dan

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 1852
  • Hero Points: 75
Re: SourceSafe not working with SlickEdit 2008
« Reply #3 on: June 10, 2008, 02:01:54 pm »
Do you receieve any sort of error message?

Do you have "Act on projects recursively" turned on in SourceSafe Options?

jorick

  • Senior Community Member
  • Posts: 320
  • Hero Points: 15
Re: SourceSafe not working with SlickEdit 2008
« Reply #4 on: June 11, 2008, 01:43:09 pm »
No error message on checkout.  The file stays read-only and if I open SourceSafe, it shows that the file never got checked out.

Conversely, if I try to check a file in using SlickEdit, it goes through the motions of giving me a comment box but the file never gets checked in on SourceSafe's side and the file stays read-write.  On SlickEdit's side, I get an error message saying "Cannot checkin the following files: [filename]  These files may not be checked out, or archives may not exist for these files"

I didn't have "Act on projects recursively" turned on.  I tried turning it on but it didn't work.

jorick

  • Senior Community Member
  • Posts: 320
  • Hero Points: 15
Re: SourceSafe not working with SlickEdit 2008
« Reply #5 on: June 11, 2008, 01:57:55 pm »
This may help...

My SourceSafe project is defined in Tools->Version Control->Setup->SourceSafe Options->Integration->Connection Information->SourceSafe project as $/New Platform.  In SourceSafe, I have a subfolder under $/New Platform named Pump where all of the files reside.  So if I need to check out a file named Command.c, it checks out $/New Platform/Pump/Command.c.

My SlickEdit workspace is Pump.vpw.  In Pump.vpw is a project called Pump.vpj which contains all of the files in the Pump project (there are other projects in the workspace as well).

When I try to do a Tools->Version Control->Properties... with one of the files in the project (Command.c for the example), it displays a dialog box that says "File not controlled" and then displays "File C:\Projects\New\Pump\Command.c (file $/Pump/Command.c in SourceSafe) was not found."  Note that it's looking for the file in $/Pump/Command.c, not $/New Platform/Pump/Command.c.

Perhaps this is the problem?  How do I get it to look into $/New Platform/Pump/Command.c instead of $/Pump/Command.c?

Dan

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 1852
  • Hero Points: 75
Re: SourceSafe not working with SlickEdit 2008
« Reply #6 on: June 11, 2008, 02:04:30 pm »
Can you open the Visual Source Safe GUI, and check the working directory for $/NewPlatform?  Does it match your local source for this project?

jorick

  • Senior Community Member
  • Posts: 320
  • Hero Points: 15
Re: SourceSafe not working with SlickEdit 2008
« Reply #7 on: June 11, 2008, 02:44:48 pm »
In the SS GUI, the working folder for $/New Platform/Pump is C:\PROJECTS\NEW\PUMP.  This is the correct folder.

jorick

  • Senior Community Member
  • Posts: 320
  • Hero Points: 15
Re: SourceSafe not working with SlickEdit 2008
« Reply #8 on: June 11, 2008, 03:00:39 pm »
I think I found it.  SlickEdit was opening the wrong SS folder on startup.  I closed the project and reopened it and now it seems to be working.

Suggestion for the next version:  In the SS login dialog box that contains the username and password, show the SS folder that it's logging in to.  It's not obvious that SS may be logging into the wrong folder on startup.

Dan

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 1852
  • Hero Points: 75
Re: SourceSafe not working with SlickEdit 2008
« Reply #9 on: June 11, 2008, 03:13:09 pm »
This is actually Source Safe's dialog box, shown by one of the SCC calls, so I am afraid we don't have any control over it.  I will remember this the next time somebody has a similar problem though.