Author Topic: something is wrong with "text file encoding" in slickedit core  (Read 10883 times)

jako

  • Community Member
  • Posts: 7
  • Hero Points: 1
in "file options" i choose "japanese(shift-jis)" for encoding as well as what i do in the "c extension option".
it seems that it is correct for every file in "japanese(shift-jis)" encoding only the first time i open it. it will give me a  big mess the next i open the file.

in slickedit it is ok.

my environment is below
winxp sp3
japanese
ie 6.0
eclipse 3.3
slickedit core 3.3.1

Ryan

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 986
  • Hero Points: 77
Re: something is wrong with "text file encoding" in slickedit core
« Reply #1 on: June 06, 2008, 02:51:22 am »
I think we already have a fix for this from another user who had file encoding problems.  Can you post one of the offending files here, or email it to support@slickedit.com?  Once I see if it's the same problem, I'll be able to get you the fix.  Thanks, and sorry for the trouble.

- Ryan

jako

  • Community Member
  • Posts: 7
  • Hero Points: 1
Re: something is wrong with "text file encoding" in slickedit core
« Reply #2 on: June 06, 2008, 12:56:09 pm »
ok
the attachment is my ".c" file.

it worked again after i change its name,and next time it failed :-[

Ryan

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 986
  • Hero Points: 77
Re: something is wrong with "text file encoding" in slickedit core
« Reply #3 on: June 06, 2008, 03:02:17 pm »
Thanks for the sample.  I see the issue, but it's not the one that we had previously fixed :(.  Looks like we are struggling to open the file within Eclipse with the correct encoding.

The problem I was referring to is one I think you should still be having...which has to do with saving any of these files within Eclipse.  Are you seeing this issue?  I have a fix for this, and if you would like I can email it to you with directions on how to install.  Send me a private message with your email address, or email support@slickedit.com and reference this thread.

The issue about the encoding I'm going to have to look into more, but I don't even think the file is opening correctly the first time for me, it's hard to tell because I'm not exactly sure what I should be seeing  ???.  Can you post a screenshot of the editor when it opens correctly, and one when it opens incorrectly?  I'll keep looking into this...

- Ryan

jako

  • Community Member
  • Posts: 7
  • Hero Points: 1
Re: something is wrong with "text file encoding" in slickedit core
« Reply #4 on: June 06, 2008, 03:46:24 pm »
the file is encoded in japanese(shift-jis)

Ryan

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 986
  • Hero Points: 77
Re: something is wrong with "text file encoding" in slickedit core
« Reply #5 on: June 09, 2008, 06:09:33 pm »
Attached is a new version of saveload.e which should hotfix the problem for 3.3.1.  Close Eclipse and go to your ECLIPSE_DIR/plugins/com.slickedit.windows.libs_3.3.1/slickedit/macros/ directory, backup the existing version of saveload.e, and save the attached version to that directory.  Then start Eclipse and load the new macro file with Macro > Load Module....

You should see the correct display every time.  Let me know if this works for you, or if you have any additional issues.  Thanks.

- Ryan

jako

  • Community Member
  • Posts: 7
  • Hero Points: 1
Re: something is wrong with "text file encoding" in slickedit core
« Reply #6 on: June 10, 2008, 02:33:39 am »
ok,it works! :P
thank you!

jako

  • Community Member
  • Posts: 7
  • Hero Points: 1
Re: something is wrong with "text file encoding" in slickedit core
« Reply #7 on: June 10, 2008, 05:32:52 am »
another problem is found ??? after apply the macro.

the line margin is disappeared.

i have tried another time ,and confirm that.

Ryan

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 986
  • Hero Points: 77
Re: something is wrong with "text file encoding" in slickedit core
« Reply #8 on: June 10, 2008, 02:19:31 pm »
So are you talking about the Word Wrap line margin?  The little line that was appearing in your editor around column 74?  That has disappeared for you because now you are actually able to view the characters in your file correctly, in Unicode.  Before it was not displaying your file correctly and it was just showing you the file in text.

There are some limitations on what we can do in the editor when displaying a file in Unicode, Word Wrap being one of them...Hex mode being another.

Is this what has disappeared?  Or did I misunderstand?

- Ryan 

jako

  • Community Member
  • Posts: 7
  • Hero Points: 1
Re: something is wrong with "text file encoding" in slickedit core
« Reply #9 on: June 10, 2008, 04:01:50 pm »
the attachment explains what i want to say ::)

Ryan

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 986
  • Hero Points: 77
Re: something is wrong with "text file encoding" in slickedit core
« Reply #10 on: June 10, 2008, 04:07:07 pm »
Great picture  :)...definite hero point for that.  Unfortunately that feature falls under the category of "things that we cannot display in a Unicode buffer"  :(.  It's a limitation of being able to view your file correctly, sorry.

- Ryan

jako

  • Community Member
  • Posts: 7
  • Hero Points: 1
Re: something is wrong with "text file encoding" in slickedit core
« Reply #11 on: June 10, 2008, 04:14:49 pm »
wow,i got it. :'(

slickedit 2008 is the same.

is it possible fix it in next edition or never will?