Author Topic: Lost search results window  (Read 6724 times)

dieters

  • New Community Member
  • Posts: 1
  • Hero Points: 0
Lost search results window
« on: June 10, 2008, 03:41:42 pm »

Slickedit v 10.0.3

I undocked the search window and while moving it around on my desktop it disappeared for some unknown reason. I have tried the view menu and various settings on the customize option for the toolbars to try and get the search window back. It is not obscured or hidden anywhere, it will not show when running a search. Nothing has worked. Any help would be appreciated.

Graeme

  • Senior Community Member
  • Posts: 2524
  • Hero Points: 329
Re: Lost search results window
« Reply #1 on: June 10, 2008, 10:47:56 pm »

Slickedit v 10.0.3

I undocked the search window and while moving it around on my desktop it disappeared for some unknown reason. I have tried the view menu and various settings on the customize option for the toolbars to try and get the search window back. It is not obscured or hidden anywhere, it will not show when running a search. Nothing has worked. Any help would be appreciated.

Here's a couple of suggestions.

With slick closed, back up your confoguration folder, then delete vslick.sta (vslick.stu on unix), then run slick.  Not sure what you lose by deleting vslick.sta but probably nothing.  If thst doesn't work, try deleting/renaming vrestore.slk  - you could try this before deleting vslick.sta actually and if it doesn't help, then "un-delete" it.

I guess you tried activate-search and toggle-search commands.  Another thing you can do is in vusrdefs.e, search for _tbfind_form and see if the settings have anything unusual  - here's what I have (in V13.0.0)  - if they do, you could edit manually, then reload by typing the full path and name of vusrdefs.e on the slick cmd line and press return - it's a batch macro file.  Another thing you could try is on the Macro menu, select open form, then _tbfind_dialog  - then right click and choose "load and run"  - dunno if this would help but who knows.

Graeme


Edit :  oops, rushing a bit much here  - forget about the _tbfind_form thing  - I guess it's the search results window you've lost, which is _tbpanel_form  - try searching for _tbpanel_form in vrestore.slk and delete any reference to it (after backing  up).



Code: [Select]
  p1__TOOLBAR=&def_toolbartab[38];
  p1__TOOLBAR->FormName='_tbfind_form';
  p1__TOOLBAR->tbflags=134;
  p1__TOOLBAR->restore_docked=0;
  p1__TOOLBAR->show_x=4875;
  p1__TOOLBAR->show_y=624;
  p1__TOOLBAR->show_width=5400;
  p1__TOOLBAR->show_height=9030;
  p1__TOOLBAR->docked_bbside=0;
  p1__TOOLBAR->docked_row=0;
  p1__TOOLBAR->docked_x=0;
  p1__TOOLBAR->docked_y=0;
  p1__TOOLBAR->docked_width=0;
  p1__TOOLBAR->docked_height=0;
  p1__TOOLBAR->tabgroup=0;
  p1__TOOLBAR->tabOrder=0;
  p1__TOOLBAR->auto_width=0;
  p1__TOOLBAR->auto_height=0;

« Last Edit: June 10, 2008, 10:57:12 pm by Graeme »

SlickEdit Support

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 337
  • Hero Points: 26
Re: Lost search results window
« Reply #2 on: June 11, 2008, 03:05:19 pm »
Excellent post as always Graeme.

Another option, if you don't have any custom toolbars or toolbar buttons setup in SlickEdit, would be to enter 'tbResetAll' (no quotes) in the SlickEdit command line (accessed by hitting Esc in most emulations.)  This will revert SlickEdit back to the standard window/toolbar view.