Author Topic: Disabling autocomplete  (Read 5282 times)

PouncingPanda

  • Community Member
  • Posts: 74
  • Hero Points: 2
Disabling autocomplete
« on: August 03, 2008, 06:01:13 am »
I cannot seem to disable autocomplete.  I have gone into

tools->options
languages->application languages->C++

and I have turned off "Enable auto-completion".  It has no apparent effect (I am coding in a C++ file).  I have restarted SE and am using version 13.

Any help would be greatly appreciated.

chrisant

  • Senior Community Member
  • Posts: 1410
  • Hero Points: 131
Re: Disabling autocomplete
« Reply #1 on: August 03, 2008, 08:43:48 am »
There are a number of features in SE that provide automatic completions.
For example "list members" is another feature that provides automatic completions.
What are you doing when you are seeing automatic completions occur?
Can you be more specific?

SlickEdit Support

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 301
  • Hero Points: 26
Re: Disabling autocomplete
« Reply #2 on: August 04, 2008, 01:54:31 pm »
Hi there,

I believe the option you are looking for is Tools --> Options --> Languages --> Application Languages --> YOUR_LANGUAGE --> Indent --> uncheck Syntax Expansion.

Regards,
SlickEdit Support

Graeme

  • Senior Community Member
  • Posts: 2422
  • Hero Points: 320
Re: Disabling autocomplete
« Reply #3 on: August 04, 2008, 02:08:54 pm »

Probably you need to uncheck a few of the auto-whatever options on the "context tagging" page of C/C++ options.

See this post by Dennis
http://community.slickedit.com/index.php?topic=2299.msg10161#msg10161

and this one
http://community.slickedit.com/index.php?topic=3387.msg13939#msg13939

Graeme


PouncingPanda

  • Community Member
  • Posts: 74
  • Hero Points: 2
Re: Disabling autocomplete
« Reply #4 on: August 05, 2008, 07:39:45 pm »
These links helped a lot, thanks guys.