Author Topic: SlickEdit Core v3.4 Now Available  (Read 4474 times)

Jeffrey

  • Community Administrator
  • Senior Community Member
  • *
  • Posts: 222
  • Hero Points: 18
SlickEdit Core v3.4 Now Available
« on: August 07, 2008, 05:24:24 pm »
SlickEdit Inc. announces the release of SlickEdit Core v3.4 for Eclipse. This release supports Eclipse Ganymede, version 3.4, and is updated with the latest capabilities from SlickEdit 2008. For a list of new features, please visit the product web page (www.slickedit.com/content/view/74/59/) and click New for Eclipse 3.4.

Some important notes about this release:

  • We have discontinued the use of Activations for licensing. With SlickEdit Core v3.4 you will need to download a license file to authenticate your license. Your license file is available on your Registered Products page (log in to www.slickedit.com then click Registered Products). This license file is portable and may be used on as many machines as you like, as long as the license is only used by you. Please refer to the End User License Agreement for full details. Your license file will not work with SlickEdit Core v3.3.


  • SlickEdit Core is a subscription that allows you to run any supported version. We recognize that many people cannot immediately move to the new version of Eclipse. So you may continue to run SlickEdit Core v3.3, which still uses Activations. You can still activate and deactivate computers to use with this version. As mentioned above, activations will not work with SlickEdit Core v3.4.


  • SlickEdit Core is installed using the Eclipse update manager. We recommend that you uninstall the previous version of SlickEdit Core prior to installing this version to the same instance of Eclipse. To download and install SlickEdit Core:

    1. Open Eclipse and select Help > Software Updates

    2. On the Available Software tab, select Add Site.

    3. Enter the URL for the SlickEdit Core update site. Please note that this URL is different for the new version. Each version of SlickEdit Core is compatible with a single version of Eclipse. To make sure that you are only shown compatible plug-ins, we have a unique URL for each version of Eclipse we support:

  • 4.Expand the tree nodes for SlickEdit Core Update Site and Code Editing, and then click the check box for the SlickEdit Core for Eclipse feature.



  • 5. Click the Install button.
  • 6. Follow the instructions in the installation wizard to accept the licensing agreement and install SlickEdit Core for Eclipse.

To learn more about SlickEdit Core, visit www.slickedit.com/content/view/74/59/.  If you have any questions, please email info@slickedit.com or call 1.919.473.0070 or 1.800.934.EDIT (USA).

Thank you,
The SlickEdit Team
« Last Edit: August 07, 2008, 05:32:06 pm by Jason »