Author Topic: line comment setup won't accept spaces  (Read 4151 times)

dmw

  • Senior Community Member
  • Posts: 145
  • Hero Points: 15
line comment setup won't accept spaces
« on: August 31, 2008, 03:09:06 pm »
I'm pretty sure that I used to be able to add trailing spaces to the comment characters in line comment setup.  I can still add them, but they are removed after clicking 'OK'. 

Can anyone offer a fix/work-around?

Thanks

hs2

  • Senior Community Member
  • Posts: 2738
  • Hero Points: 288
Re: line comment setup won't accept spaces
« Reply #1 on: September 04, 2008, 11:58:41 pm »
Hmm - this is (still) working as it used to be (compared v12.0.3 vs. v13.0.2).
HS2

hs2

  • Senior Community Member
  • Posts: 2738
  • Hero Points: 288
Re: line comment setup won't accept spaces
« Reply #2 on: September 05, 2008, 01:15:55 am »
BTW: You might check your <SE-config-dir>/user.vlx file (ini file format) which contains your language lexer mods including the 'linecomment' key.
e.g.
Code: [Select]
[Batch]
...
linecomment="@REM "
...
Good luck, HS2
« Last Edit: September 05, 2008, 01:17:44 am by hs2 »

mrothman

  • Senior Community Member
  • Posts: 120
  • Hero Points: 1
Re: line comment setup won't accept spaces
« Reply #3 on: December 11, 2009, 07:29:58 pm »
For what it's worth, a year later, I was having the same problem.  That is, when I select and line comment this (in C++):

This is a comment

it became

//This is a comment

But I wanted this:

// This is a comment

And adding a trailing space to the Comment line characters in the Options configuration GUI didn't stick.

The user.vlx file no longer seems to be the place to go (at least on linux), but instead I found that ubox.ini appears to store the differences in each language comment configuration.  And using '\s' allowed me to specify a trailing space after the // line comment character (for c++).  Here's what the syntax in that file looks like:

nonboxchars=left=//\s right=\e  (color added to emphasize my change)

Now it works!


David_O

  • Senior Community Member
  • Posts: 152
  • Hero Points: 8
Re: line comment setup won't accept spaces
« Reply #4 on: December 15, 2009, 02:55:30 pm »
What version of SE are you using?  Line comments are working with trailing spaces in the current 2009 release.

I take that back (and should have been more thorough).  We were able to reproduce this.  We'll get a fix in the next release or hotfix.

Thanks,
« Last Edit: December 15, 2009, 03:55:25 pm by David_O »