Author Topic: Problems with build and vers. 13.0.2  (Read 5644 times)

deuse

  • Community Member
  • Posts: 33
  • Hero Points: 0
Problems with build and vers. 13.0.2
« on: September 01, 2008, 04:14:47 pm »
Hi,
since I've updated to 13.0.2 (from 13.0.0...), I had to encounter some strange behaviour when I start compiling my project (C#, MSVS-2005) from within slick:
- the build output window doesn't always show the bottom of the compiler messages, sometimes it shows the top (which makes no sense for me, I want to see if the compile worked or failed), sometimes the end of the messages (bottom).
- sometimes suddenly one of my source files gets loaded by visual studio (which is started if it wasn't running) and also Irfanview (my default viewing program) starts loading one of my icon files
Strange...
This happens in appr. 50% of the builds, so it gets more and more annoying.
With former versions of slick, this behaviour didn't occur.
Maybe I should mention the following: I bound the workspace-build command to C-B C-B (the first C-B is a prefix key). Maybe it has todo with the timing? I tried to enter it fast or slow, but I couldn't find a relation.
Best Regards
Rudi

lambertia

  • Senior Community Member
  • Posts: 382
  • Hero Points: 14
  • I have nothing sufficiently witty to say.
Re: Problems with build and vers. 13.0.2
« Reply #1 on: September 02, 2008, 06:08:26 am »
Hi.

The next time this happens, do "netstat -an" from the command prompt (in the OS, not SE) and see how many listeners there are on port 9009.

It may be related to (http://community.slickedit.com/index.php?topic=3840.msg16166#msg16166).

Cheers,
--
Greg.

deuse

  • Community Member
  • Posts: 33
  • Hero Points: 0
Re: Problems with build and vers. 13.0.2
« Reply #2 on: September 02, 2008, 07:46:29 am »
One, but...:
   C:\abc>netstat -an
   Aktive Verbindungen
     Proto  Lokale Adresse         Remoteadresse          Status
... cut ...
     TCP    127.0.0.1:1309         127.0.0.1:9009         WARTEND
     TCP    127.0.0.1:9009         0.0.0.0:0              ABHÖREN
... cut ...
   C:\abc>
Hope this will help...
Translations:
WARTEND=waiting
ABHÖREN=listening
Prost
Rudi
« Last Edit: September 02, 2008, 07:50:04 am by deuse »

lambertia

  • Senior Community Member
  • Posts: 382
  • Hero Points: 14
  • I have nothing sufficiently witty to say.
Re: Problems with build and vers. 13.0.2
« Reply #3 on: September 02, 2008, 09:30:33 pm »
Hi.

What you see there is expected. The Listening one is SE waiting for connections. The other one is in the process of shutting down its connection. So its all normal there.

Cheers,
--
Greg.

deuse

  • Community Member
  • Posts: 33
  • Hero Points: 0
Re: Problems with build and vers. 13.0.2
« Reply #4 on: September 03, 2008, 10:25:31 am »
Ok, but how will this continue? Are you going to find a solution? Maybe it would be a hint to look what has been changed between 13.0.0 and 13.0.2. With <= 13.0.0, this problem didn't occur.

Greetz
Rudi

Lee

  • SlickEdit Team Member
  • Senior Community Member
  • *
  • Posts: 1299
  • Hero Points: 130
Re: Problems with build and vers. 13.0.2
« Reply #5 on: September 03, 2008, 01:02:42 pm »
I don't fully understand the problem, are you saying that the output in the Build window is incomplete or being cutoff?  Could you provide an example of what your seeing, or a sample project that exhibits this behavior? You should report this along with any relevant info (Platform, Emulation) to SlickEdit support (support@slickedit.com).  As for files being loaded into other applications, file types can configured in SlickEdit to be opened by a different application when you double-click on them in the Projects tool window.  It's configured in the Languages > File Extension Manager in the options.  For example .bmp and .ico files are configured to use whatever file association that the OS Shell is configured to open with (Use file association option).

deuse

  • Community Member
  • Posts: 33
  • Hero Points: 0
Re: Problems with build and vers. 13.0.2
« Reply #6 on: September 05, 2008, 12:53:09 pm »
Thanks, Greg and Lee, for your help.

@Greg: I wasn't aware that the support e-mail address from MicroEdge/SlickEdit Inc. is still active. Instead I thougt that now this forum is the contact point for support issues and that you were a technical employee of SlickEdit Inc. Sorry!

@Lee:
@AllOthers:
Of course I know about the file type association mechanism. The problem is that Slick calls the viewer and the VS unexpectedly during the compile procedure.

I checked the output buffer, here is a cutout:
>    Der Pfad C:\D\Cs\Mis\obj\Debug\Mis.Icons.MisDunkelgrauGrau.ico befindet sich auáerhalb des Vergleichspfades.
>    Der Pfad C:\D\Cs\Mis\obj\Debug\Mis.Icons.MisGrau.ico befindet sich auáerhalb des Vergleichspfades.
>    Der Pfad C:\D\Cs\Mis\obj\Debug\Mis.Icons.MisGrau16x16.ico befindet sich auáerhalb des Vergleichspfades.
>    Der Pfad C:\D\Cs\Mis\obj\Debug\Mis.Icons.MisGrau32x32.ico befindet sich auáerhalb des Vergleichspfades.
>designer.cs Source\FrmsObjs\FrmAdressen.cs     Der Pfad C:\D\Cs\Mis\obj\Debug\Mis.Icons.MisWeiss.ico befindet sich auáerhalb des Vergleichspfades.
>    Der Pfad C:\D\Cs\Mis\obj\Debug\Mis.MisGrau.ico befindet sich auáerhalb des Vergleichspfades.
>    Der Pfad C:\D\Cs\Mis\obj\Debug\Mis.Properties.Resources.resources befindet sich auáerhalb des Vergleichspfades.
>    Der Pfad C:\D\Cs\Mis\obj\Debug\Mis.FrmStart.resources befindet sich auáerhalb des Vergleichspfades.
>    Der Pfad C:\D\Cs\Mis\obj\Debug\Mis.FrmAuftrag.resources befindet sich auáerhalb des Vergleichspfades.

As you can see, the line "designer.cs..." doesn't fit at this place. Correct would be:
>    Der Pfad C:\D\Cs\Mis\obj\Debug\Mis.Icons.MisDunkelgrauGrau.ico befindet sich auáerhalb des Vergleichspfades.
>    Der Pfad C:\D\Cs\Mis\obj\Debug\Mis.Icons.MisGrau.ico befindet sich auáerhalb des Vergleichspfades.
>    Der Pfad C:\D\Cs\Mis\obj\Debug\Mis.Icons.MisGrau16x16.ico befindet sich auáerhalb des Vergleichspfades.
>    Der Pfad C:\D\Cs\Mis\obj\Debug\Mis.Icons.MisGrau32x32.ico befindet sich auáerhalb des Vergleichspfades.
>    Der Pfad C:\D\Cs\Mis\obj\Debug\Mis.Icons.MisWeiss.ico befindet sich auáerhalb des Vergleichspfades.
>    Der Pfad C:\D\Cs\Mis\obj\Debug\Mis.MisGrau.ico befindet sich auáerhalb des Vergleichspfades.
>    Der Pfad C:\D\Cs\Mis\obj\Debug\Mis.Properties.Resources.resources befindet sich auáerhalb des Vergleichspfades.
>    Der Pfad C:\D\Cs\Mis\obj\Debug\Mis.FrmStart.resources befindet sich auáerhalb des Vergleichspfades.
>    Der Pfad C:\D\Cs\Mis\obj\Debug\Mis.FrmAuftrag.resources befindet sich auáerhalb des Vergleichspfades.

It seems that the output stream is not captured properly.

IMHO: Because of the unexpected "designer.cs", VS gets confused. Later, it tries to handle "designer.cs" and calls
a) VS with loading a souce file
b) the viewer program with an icon file

Here's the end of the output buffer (=build window):
>Erstellen des Projekts Mis.csproj beendet - Fehler beim Erstellen.
>
>Fehler beim Buildvorgang.
>
>Vergangene Zeit 00:00:01.79
>========== Build: 0 erfolgreich oder aktuell, Fehler bei 1, 0 �bersprungen ==========
>
>C:\D\Cs\Mis>C:\D\Cs\Mis>
>C:\D\Cs\Mis>Der Befehl "designer.cs" ist entweder falsch geschrieben oder
>konnte nicht gefunden werden.
Some Translations:
The command "designer.cs" is either wrong or couldn't been found.
erfolgreich=successfull
Fehler=Error

BTW: I'm not quite sure yet, but it seems that the problem described only occures when there are some errors in the source code.
Doing the build with an error-free code always succeeded.

I'll do some more test and forward this issue to slickedit support.
« Last Edit: September 08, 2008, 12:05:36 pm by deuse »

lambertia

  • Senior Community Member
  • Posts: 382
  • Hero Points: 14
  • I have nothing sufficiently witty to say.
Re: Problems with build and vers. 13.0.2
« Reply #7 on: September 06, 2008, 12:11:54 am »
Hi Mate.

I don't work for SE ;)

Cheers,
--
Greg.